summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b1ff84c07a2..463b52d07f23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = ocaml-lambda-term
install = ocaml-lambda-term.install
arch = x86_64
arch = aarch64
- license = BSD
+ license = BSD-3-Clause
makedepends = dune>=3.0.0
depends = ocaml>=4.08.0
depends = ocaml-logs_lwt
@@ -14,6 +14,7 @@ pkgbase = ocaml-lambda-term
depends = ocaml-mew_vi>=0.5.0
depends = ocaml-react
depends = ocaml-zed>=3.2.0
+ depends = libev
options = !strip
source = ocaml-lambda-term-3.3.2.tar.gz::https://github.com/ocaml-community/lambda-term/archive/3.3.2.tar.gz
sha512sums = 78648768644058337e22c79cf1fbb1a36472b24f11b1dc0461fc38419be6ec01b02d8d0ac45fed0bc99f91ba4c0f19d3bda113e834e064bee973b734527b9766
diff --git a/.gitignore b/.gitignore
index 004b0a3a8706..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
# which causes the gitignore file to apply to them too, which breaks some builds
-# Based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
/*.tar
/*.tar.*
/*.rpm
diff --git a/PKGBUILD b/PKGBUILD
index a52c68043f71..41cea50ac7bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ pkgrel='2'
pkgdesc='Terminal manipulation library for OCaml'
arch=('x86_64' 'aarch64')
url="https://github.com/ocaml-community/$_projectname"
-license=('BSD')
-depends=('ocaml>=4.08.0' 'ocaml-logs_lwt' 'ocaml-lwt>=4.2.0' 'ocaml-mew_vi>=0.5.0' 'ocaml-react' 'ocaml-zed>=3.2.0')
+license=('BSD-3-Clause')
+depends=('ocaml>=4.08.0' 'ocaml-logs_lwt' 'ocaml-lwt>=4.2.0' 'ocaml-mew_vi>=0.5.0' 'ocaml-react' 'ocaml-zed>=3.2.0' 'libev')
makedepends=('dune>=3.0.0')
options=('!strip')
install="$pkgname.install"
@@ -33,5 +33,5 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
}