summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c8848c9ff17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Fri Apr 10 23:35:49 UTC 2015
+pkgbase = ocaml-mysql
+ pkgdesc = OCaml bindings for MySQL
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = http://ocaml-mysql.forge.ocamlcore.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = ocaml
+ makedepends = ocaml-findlib
+ makedepends = libmysqlclient
+ depends = camlp4
+ options = !strip
+ options = staticlibs
+ source = https://forge.ocamlcore.org/frs/download.php/1472/ocaml-mysql-1.2.0.tar.gz
+ md5sums = 81d3bf217e4ed1829b9ea19f037dce65
+
+pkgname = ocaml-mysql
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f3c8988f347
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: oliver < a t > first . in-berlin . de
+# Contributor: Gregory BELLIER <gregory.bellier -- gmail -- com>
+
+pkgname=ocaml-mysql
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="OCaml bindings for MySQL"
+arch=('i686' 'x86_64')
+url="http://ocaml-mysql.forge.ocamlcore.org/"
+license=('LGPL')
+makedepends=('ocaml' 'ocaml-findlib' 'libmysqlclient')
+depends=(camlp4)
+options=('!strip' 'staticlibs')
+#install=
+source=(https://forge.ocamlcore.org/frs/download.php/1472/ocaml-mysql-$pkgver.tar.gz)
+md5sums=('81d3bf217e4ed1829b9ea19f037dce65')
+
+build() {
+
+ cd "$srcdir/ocaml-mysql-$pkgver"
+
+ ./configure || return 1
+ make reallyall || return 1
+
+}
+
+package() {
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ export OCAMLFIND_LDCONF="ignore"
+
+ cd "$srcdir/ocaml-mysql-$pkgver"
+ install -d $OCAMLFIND_DESTDIR || return 1
+
+ make install || return 1
+
+}
+
+# vim:set ts=2 sw=2 et: