summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a7ed1ffbc73..718c87dd6e26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ocplib-endian
pkgdesc = Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays
pkgver = 1.2
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/OCamlPro/ocplib-endian
arch = x86_64
arch = aarch64
@@ -11,6 +11,8 @@ pkgbase = ocaml-ocplib-endian
depends = ocaml>=4.03.0
options = !strip
source = ocaml-ocplib-endian-1.2.tar.gz::https://github.com/OCamlPro/ocplib-endian/archive/1.2.tar.gz
+ source = ocaml-ocplib-endian-1.2-remove-bytes-dep.diff::https://github.com/OCamlPro/ocplib-endian/pull/26.diff
sha512sums = 2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85
+ sha512sums = 6199b7032bb3939513de1376966c595fc47e8204f2ba96d6909897378ed18f88e39d81bdabb09c4669c092eacdb8c600fccde733d61677890093b2a50bb90bf0
pkgname = ocaml-ocplib-endian
diff --git a/PKGBUILD b/PKGBUILD
index 1fdb9fa59c70..f5b800835d09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_projectname='ocplib-endian'
pkgname="ocaml-$_projectname"
pkgver='1.2'
-pkgrel='6'
+pkgrel='7'
pkgdesc='Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays'
arch=('x86_64' 'aarch64')
url="https://github.com/OCamlPro/$_projectname"
@@ -11,11 +11,22 @@ license=('LGPL-2.1-or-later WITH OCaml-LGPL-linking-exception')
depends=('ocaml>=4.03.0')
makedepends=('cppo' 'dune>=1.0.0')
options=('!strip')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85')
+source=(
+ "$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ "$pkgname-$pkgver-remove-bytes-dep.diff::$url/pull/26.diff"
+)
+sha512sums=('2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85'
+ '6199b7032bb3939513de1376966c595fc47e8204f2ba96d6909897378ed18f88e39d81bdabb09c4669c092eacdb8c600fccde733d61677890093b2a50bb90bf0')
_sourcedirectory="$_projectname-$pkgver"
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+
+ # Make sure we don't directly depend on bytes, as that stopped working in ocaml 5.0 (https://github.com/OCamlPro/ocplib-endian/pull/26)
+ patch --forward -p1 < "../$pkgname-$pkgver-remove-bytes-dep.diff"
+}
+
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose