summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rw-r--r--dirs.patch2
3 files changed, 5 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7f82bc3fb31..a08561a60b9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ocplib-simplex-git
pkgdesc = simplex algorithm implementation for solving systems of linear inequalities and optimizing linear objective functions
pkgver = 0.5.r0.g9b0944c
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/OCamlPro-Iguernlala/ocplib-simplex
arch = i686
arch = x86_64
@@ -17,6 +17,6 @@ pkgbase = ocaml-ocplib-simplex-git
source = git+https://github.com/OCamlPro-Iguernlala/ocplib-simplex
source = dirs.patch
sha256sums = SKIP
- sha256sums = 8640fee9d5f773a79e992c564555b0448763e8a4d15060571984df7f754afb50
+ sha256sums = 18b406548801f5c54b3f2fce5dcd56ad94f923cbe81b93d9c0aa4df0e76f5c8a
pkgname = ocaml-ocplib-simplex-git
diff --git a/PKGBUILD b/PKGBUILD
index f6808f6937be..d2e0436d65d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=ocaml-ocplib-simplex-git
pkgver=0.5.r0.g9b0944c
-pkgrel=3
+pkgrel=4
pkgdesc='simplex algorithm implementation for solving systems of linear inequalities and optimizing linear objective functions'
url='https://github.com/OCamlPro-Iguernlala/ocplib-simplex'
@@ -17,7 +17,7 @@ source=('git+https://github.com/OCamlPro-Iguernlala/ocplib-simplex'
'dirs.patch')
sha256sums=('SKIP'
- '8640fee9d5f773a79e992c564555b0448763e8a4d15060571984df7f754afb50')
+ '18b406548801f5c54b3f2fce5dcd56ad94f923cbe81b93d9c0aa4df0e76f5c8a')
pkgver() {
cd ocplib-simplex
@@ -43,18 +43,4 @@ check() {
package() {
cd ocplib-simplex
make LIBDIR="$(ocamlc -where)" DESTDIR="$pkgdir" install
-
- # Workaround the install of docs to 'tmp' or 'home' folder.
- #
- if [ -d "$pkgdir/tmp" ];
- then
- mv "$pkgdir/tmp/makepkg/ocaml-ocplib-simplex-git/pkg/ocaml-ocplib-simplex-git/usr/share" \
- "$pkgdir/usr"
- rm -fr "$pkgdir/tmp"
-
- else
- mv "$pkgdir/home/makepkg/ocaml-ocplib-simplex-git/pkg/ocaml-ocplib-simplex-git/usr/share" \
- "$pkgdir/usr"
- rm -fr "$pkgdir/home"
- fi
}
diff --git a/dirs.patch b/dirs.patch
index e28508537a48..258eb5ba7a41 100644
--- a/dirs.patch
+++ b/dirs.patch
@@ -6,7 +6,7 @@ diff --color --unified --recursive --text ocplib-simplex.orig/Makefile ocplib-si
install: build
- @dune install
-+ @dune install --mandir="$(DESTDIR)/usr/share/man/" --docdir="$(DESTDIR)/usr/share/doc/" --etcdir="$(DESTDIR)/etc/" --datadir="$(DESTDIR)/opt/" --sbindir="$(DESTDIR)/sbin/" --bindir="$(DESTDIR)/usr/bin/"
++ @dune install --mandir="$(DESTDIR)/usr/share/man/" --docdir="/usr/share/doc/" --etcdir="$(DESTDIR)/etc/" --datadir="$(DESTDIR)/opt/" --sbindir="$(DESTDIR)/sbin/" --bindir="$(DESTDIR)/usr/bin/"
uninstall:
@dune uninstall