summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0e94a14f55a..9cd98df46049 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Mar 23 10:50:54 UTC 2016
pkgbase = ocaml-pcre
pkgdesc = Perl compatible regular expressions for OCaml
- pkgver = 7.1.6
+ pkgver = 7.2.3
pkgrel = 1
url = http://mmottl.github.io/pcre-ocaml
arch = i686
@@ -12,8 +14,8 @@ pkgbase = ocaml-pcre
replaces = pcre-ocaml
options = !strip
options = staticlibs
- source = https://github.com/mmottl/pcre-ocaml/releases/download/v7.1.6/pcre-ocaml-7.1.6.tar.gz
- md5sums = d5c2230bc8123ed382d018737f26a0d5
+ source = https://github.com/mmottl/pcre-ocaml/releases/download/v7.2.3/pcre-ocaml-7.2.3.tar.gz
+ md5sums = 90b503355160d7422a7c3ef1623e6444
pkgname = ocaml-pcre
diff --git a/PKGBUILD b/PKGBUILD
index 2a7e8f789049..2ac9dddc54d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Magnus Therning <magnus@therning.org>
pkgname=ocaml-pcre
-pkgver=7.1.6
+pkgver=7.2.3
pkgrel=1
pkgdesc="Perl compatible regular expressions for OCaml"
arch=('i686' 'x86_64')
@@ -17,19 +17,21 @@ replaces=('pcre-ocaml')
conflicts=('pcre-ocaml')
options=('!strip' 'staticlibs')
source=("https://github.com/mmottl/pcre-ocaml/releases/download/v$pkgver/pcre-ocaml-$pkgver.tar.gz")
-md5sums=('d5c2230bc8123ed382d018737f26a0d5')
+md5sums=('90b503355160d7422a7c3ef1623e6444')
build() {
- cd "$srcdir/pcre-ocaml-$pkgver"
+ cd "${srcdir}/pcre-ocaml-${pkgver}"
- ./configure --disable-debug --prefix /usr --destdir "$pkgdir"
+ ./configure --disable-debug --prefix /usr --destdir "${pkgdir}"
make all
}
package() {
- cd "$srcdir/pcre-ocaml-$pkgver"
- export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
- install -dm 755 "$OCAMLFIND_DESTDIR/stublibs"
+ cd "${srcdir}/pcre-ocaml-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ install -dm 755 "${OCAMLFIND_DESTDIR}/stublibs"
make install
- install -Dm 644 COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ mv "${pkgdir}/usr/share/doc/pcre" "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 COPYING.txt "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}