summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD51
4 files changed, 67 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e220e81e543..2dd243135cbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
-# Generated by mksrcinfo v8
-# Wed Jun 27 19:25:19 UTC 2018
pkgbase = ocaml-ppx_deriving
- pkgdesc = Type-driven code generation for OCaml >=4.02
- pkgver = 4.2.1
+ pkgdesc = Type-driven code generation for OCaml >=4.02.2
+ pkgver = 4.4.1
pkgrel = 1
url = https://github.com/ocaml-ppx/ppx_deriving
- arch = i686
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = MIT
- makedepends = ocamlbuild
- makedepends = ocaml-findlib
+ checkdepends = ocaml-ounit
makedepends = cppo
- depends = ocaml
+ makedepends = dune>=1.6.3
+ makedepends = ocaml-findlib
+ makedepends = ocaml-ppxfind
+ depends = ocaml>=4.02.2
depends = ocaml-migrate-parsetree
depends = ocaml-ppx_derivers
depends = ocaml-ppx_tools
depends = ocaml-result
- source = https://github.com/ocaml-ppx/ppx_deriving/archive/v4.2.1.tar.gz
- md5sums = 2195fccf2a527c3ff9ec5b4e36e2f0a8
+ options = !strip
+ source = ocaml-ppx_deriving-4.4.1-1.tar.gz::https://github.com/ocaml-ppx/ppx_deriving/archive/v4.4.1.tar.gz
+ sha256sums = 27bc57774724fc4f48775f2011375a5ee1439570204abbf6607761c472757e2f
pkgname = ocaml-ppx_deriving
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index d03c27314445..3ce434d07701 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,40 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-_pkgname=ppx_deriving
-pkgname=ocaml-${_pkgname}
-pkgver=4.2.1
-pkgrel=1
-pkgdesc="Type-driven code generation for OCaml >=4.02"
-arch=('i686' 'x86_64')
-url="https://github.com/ocaml-ppx/ppx_deriving"
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ppx_deriving'
+pkgname="ocaml-$_projectname"
+pkgver='4.4.1'
+pkgrel='1'
+pkgdesc='Type-driven code generation for OCaml >=4.02.2'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml' 'ocaml-migrate-parsetree' 'ocaml-ppx_derivers' 'ocaml-ppx_tools' 'ocaml-result')
-makedepends=('ocamlbuild' 'ocaml-findlib' 'cppo')
-source=("https://github.com/ocaml-ppx/${_pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('2195fccf2a527c3ff9ec5b4e36e2f0a8')
+depends=('ocaml>=4.02.2' 'ocaml-migrate-parsetree' 'ocaml-ppx_derivers' 'ocaml-ppx_tools' 'ocaml-result')
+makedepends=('cppo' 'dune>=1.6.3' 'ocaml-findlib' 'ocaml-ppxfind')
+checkdepends=('ocaml-ounit')
+options=('!strip')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('27bc57774724fc4f48775f2011375a5ee1439570204abbf6607761c472757e2f')
+
+_sourcedirectory="$_projectname-$pkgver"
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
+}
- make
+check() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune runtest -p "$_projectname" --verbose
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
- export OCAMLPATH="$(ocamlc -where):${pkgdir}$(ocamlc -where)"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}"
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
- make install
- install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}