summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de48ebe298ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Jun 28 15:10:22 UTC 2018
+pkgbase = ocaml-ppx_hash
+ pkgdesc = A ppx rewriter that generates hash functions from type expressions and definitions
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://github.com/janestreet/ppx_hash
+ arch = x86_64
+ license = Apache
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-base
+ depends = ocaml-ppx_compare
+ depends = ocaml-ppx_sexp_conv
+ depends = ocaml-migrate-parsetree
+ depends = ocaml-ppxlib
+ options = !strip
+ source = https://github.com/janestreet/ppx_hash/archive/v0.11.1.tar.gz
+ md5sums = 48dfe890e195808ccdae0a7261bbb17d
+
+pkgname = ocaml-ppx_hash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..024dca6d76c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ppx_hash
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="A ppx rewriter that generates hash functions from type expressions and definitions"
+arch=('x86_64')
+url='https://github.com/janestreet/ppx_hash'
+license=('Apache')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_sexp_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+makedepends=('dune')
+options=('!strip')
+source=("https://github.com/janestreet/ppx_hash/archive/v${pkgver}.tar.gz")
+md5sums=('48dfe890e195808ccdae0a7261bbb17d')
+
+build() {
+ cd "${srcdir}/ppx_hash-${pkgver}"
+
+ jbuilder build
+}
+
+
+package() {
+ cd "${srcdir}/ppx_hash-${pkgver}"
+
+ mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}