summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de48ebe298ff..2c22f35b43f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 15:10:22 UTC 2018
pkgbase = ocaml-ppx_hash
pkgdesc = A ppx rewriter that generates hash functions from type expressions and definitions
- pkgver = 0.11.1
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/janestreet/ppx_hash
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
depends = ocaml-ppx_compare
depends = ocaml-ppx_sexp_conv
- depends = ocaml-migrate-parsetree
depends = ocaml-ppxlib
options = !strip
- source = https://github.com/janestreet/ppx_hash/archive/v0.11.1.tar.gz
- md5sums = 48dfe890e195808ccdae0a7261bbb17d
+ source = https://github.com/janestreet/ppx_hash/archive/v0.12.0.tar.gz
+ sha512sums = bc703cb88ec2ecfc3af8890bc231c3e93ae68caadb6917d2bc7b7f30ca210bfda559d94cd562d5ecaf8ac7178d9219499ffbdb1042d1c83d68646106546ef0ec
pkgname = ocaml-ppx_hash
diff --git a/PKGBUILD b/PKGBUILD
index 024dca6d76c5..ce12fe824a8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_hash
-pkgver=0.11.1
+pkgver=0.12.0
pkgrel=1
pkgdesc="A ppx rewriter that generates hash functions from type expressions and definitions"
arch=('x86_64')
url='https://github.com/janestreet/ppx_hash'
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_sexp_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_sexp_conv' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip')
source=("https://github.com/janestreet/ppx_hash/archive/v${pkgver}.tar.gz")
-md5sums=('48dfe890e195808ccdae0a7261bbb17d')
+sha512sums=('bc703cb88ec2ecfc3af8890bc231c3e93ae68caadb6917d2bc7b7f30ca210bfda559d94cd562d5ecaf8ac7178d9219499ffbdb1042d1c83d68646106546ef0ec')
build() {
cd "${srcdir}/ppx_hash-${pkgver}"
- jbuilder build
+ dune build
}
@@ -24,6 +24,7 @@ package() {
cd "${srcdir}/ppx_hash-${pkgver}"
mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}