summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a17ca2fa1034..a56d64201059 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 00:06:38 UTC 2018
pkgbase = ocaml-ppx_sexp_conv
pkgdesc = Generation of S-expression conversion functions from type definitions
- pkgver = 0.11.2
+ pkgver = 0.12.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_sexp_conv
arch = i686
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
- depends = ocaml-migrate-parsetree
- depends = ocaml-ppxlib
depends = ocaml-sexplib0
+ depends = ocaml-ppxlib
options = !strip
- source = https://github.com/janestreet/ppx_sexp_conv/archive/v0.11.2.tar.gz
- md5sums = 77d3b30b3d9c5810552bde2027656b8d
+ source = https://github.com/janestreet/ppx_sexp_conv/archive/v0.12.0.tar.gz
+ sha512sums = f6adca0cf1aa9edef034425c586749879f8dcdbd2375e5c77bfa57dba37b024d0fdaeea97009c10891d3d6dac7240da554350b47a22af9d2f9fbbf758d8426a0
pkgname = ocaml-ppx_sexp_conv
diff --git a/PKGBUILD b/PKGBUILD
index 8274dfb8b91d..37dc7870b259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_sexp_conv
-pkgver=0.11.2
+pkgver=0.12.0
pkgrel=1
epoch=1
pkgdesc="Generation of S-expression conversion functions from type definitions"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_sexp_conv"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-migrate-parsetree' 'ocaml-ppxlib' 'ocaml-sexplib0')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-sexplib0' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip')
source=("https://github.com/janestreet/ppx_sexp_conv/archive/v${pkgver}.tar.gz")
-md5sums=('77d3b30b3d9c5810552bde2027656b8d')
+sha512sums=('f6adca0cf1aa9edef034425c586749879f8dcdbd2375e5c77bfa57dba37b024d0fdaeea97009c10891d3d6dac7240da554350b47a22af9d2f9fbbf758d8426a0')
build() {
cd "${srcdir}/ppx_sexp_conv-${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/ppx_sexp_conv-${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}