summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--exedir.patch10
3 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e72180799d23..1cca4ca34deb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 02:38:25 UTC 2016
+# Fri Jul 29 12:11:23 UTC 2016
pkgbase = ocaml-ppx_sexp_value
pkgdesc = A ppx rewriter that simplifies building s-expressions from ocaml values
- pkgver = 113.24.00
+ pkgver = 113.33.03
pkgrel = 1
url = https://github.com/janestreet/ppx_sexp_value
arch = i686
arch = x86_64
license = Apache
makedepends = ocaml-findlib
+ makedepends = ocaml-js-build-tools
makedepends = opam
depends = ocaml
depends = ocaml-ppx_core
@@ -17,10 +18,13 @@ pkgbase = ocaml-ppx_sexp_value
depends = ocaml-ppx_sexp_conv
depends = ocaml-ppx_tools
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.24/files/ppx_sexp_value-113.24.00.tar.gz
+ options = !emptydirs
+ source = https://ocaml.janestreet.com/ocaml-core/113.33/files/ppx_sexp_value-113.33.03.tar.gz
source = libdir.patch
- md5sums = 8a16a9b1f74a59e8a1fa11d65ff39842
+ source = exedir.patch
+ md5sums = 0582ea3bc8edddc6bb8731514059da84
md5sums = 7f0a951f1ac87385272ea7a6dd58762a
+ md5sums = e155286965bf825c87fbeca63fa53e01
pkgname = ocaml-ppx_sexp_value
diff --git a/PKGBUILD b/PKGBUILD
index 48321e1abf96..087ea0d6e6a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_sexp_value
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="A ppx rewriter that simplifies building s-expressions from ocaml values"
url="https://github.com/janestreet/ppx_sexp_value"
depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('8a16a9b1f74a59e8a1fa11d65ff39842'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('0582ea3bc8edddc6bb8731514059da84'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ 'e155286965bf825c87fbeca63fa53e01')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {
diff --git a/exedir.patch b/exedir.patch
new file mode 100644
index 000000000000..ce24d0123153
--- /dev/null
+++ b/exedir.patch
@@ -0,0 +1,10 @@
+diff -aur package.pristine/install.ml package.new/install.ml
+--- package.pristine/install.ml 2016-07-29 14:09:26.249120030 +0200
++++ package.new/install.ml 2016-07-29 14:09:39.215695571 +0200
+@@ -6,5 +6,5 @@
+ generate ~package:"ppx_sexp_value"
+ [ oasis_lib "ppx_sexp_value"
+ ; file "META" ~section:"lib"
+- ; oasis_exe "ppx" ~dest:"../lib/ppx_sexp_value/ppx"
++ ; oasis_exe "ppx" ~dest:"../lib/ocaml/ppx_sexp_value/ppx"
+ ]