summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 750c2b5b917a..72a02ebb68d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_typerep_conv
pkgdesc = Generation of runtime types from type declarations
- pkgver = 0.14.2
- pkgrel = 2
+ pkgver = 0.15.0
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_typerep_conv
arch = x86_64
@@ -12,12 +12,12 @@ pkgbase = ocaml-ppx_typerep_conv
arch = aarch64
license = MIT
makedepends = dune>=2.0.0
- depends = ocaml>=4.04.2
- depends = ocaml-base>=0.14.0
- depends = ocaml-typerep>=0.14.0
- depends = ocaml-ppxlib>=0.22.0
+ depends = ocaml>=4.08.0
+ depends = ocaml-base>=0.15.0
+ depends = ocaml-typerep>=0.15.0
+ depends = ocaml-ppxlib>=0.23.0
options = !strip
- source = ocaml-ppx_typerep_conv-1:0.14.2-2.tar.gz::https://github.com/janestreet/ppx_typerep_conv/archive/v0.14.2.tar.gz
- sha256sums = 1670dc267cacc8ea27a0b3aab4c08ed13fd622280e8169b93cea329def583abc
+ source = ocaml-ppx_typerep_conv-1:0.15.0-1.tar.gz::https://github.com/janestreet/ppx_typerep_conv/archive/v0.15.0.tar.gz
+ sha512sums = 3f5bb2c70674e5f6219daa883fe948023a60558c9560c5d8e6b187e0420adf8767ce4f5cca06fe7edccd52e531b2e79d962f7fdc7502cb63280c364627621c73
pkgname = ocaml-ppx_typerep_conv
diff --git a/PKGBUILD b/PKGBUILD
index 9c3317d53491..b83e32432fb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_typerep_conv'
pkgname="ocaml-$_projectname"
-pkgver='0.14.2'
-pkgrel='2'
+pkgver='0.15.0'
+pkgrel='1'
epoch='1'
pkgdesc='Generation of runtime types from type declarations'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-typerep>=0.14.0' 'ocaml-ppxlib>=0.22.0')
+depends=('ocaml>=4.08.0' 'ocaml-base>=0.15.0' 'ocaml-typerep>=0.15.0' 'ocaml-ppxlib>=0.23.0')
makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('1670dc267cacc8ea27a0b3aab4c08ed13fd622280e8169b93cea329def583abc')
+sha512sums=('3f5bb2c70674e5f6219daa883fe948023a60558c9560c5d8e6b187e0420adf8767ce4f5cca06fe7edccd52e531b2e79d962f7fdc7502cb63280c364627621c73')
_sourcedirectory="$_projectname-$pkgver"