summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 018d13808c56..af713ec677aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 02:52:20 UTC 2016
pkgbase = ocaml-re
pkgdesc = Pure OCaml regular expressions, with support for Perl and POSIX-style strings
- pkgver = 1.4.1
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/ocaml/ocaml-re
arch = i686
@@ -9,8 +11,8 @@ pkgbase = ocaml-re
makedepends = ocaml-findlib
depends = ocaml
options = !strip
- source = ocaml-re-1.4.1.tar.gz::https://codeload.github.com/ocaml/ocaml-re/tar.gz/ocaml-re-1.4.1
- sha256sums = 262554309d645f4126a2a2e21e3a798d250293264fda34d6271243cc6c16e576
+ source = https://github.com/ocaml/ocaml-re/archive/ocaml-re-1.5.0.tar.gz
+ sha256sums = 53322f763a8d771a68f986c9c323cab7d3afa56873c3eefa528fb92b1b511dd3
pkgname = ocaml-re
diff --git a/PKGBUILD b/PKGBUILD
index 9a0b93b4c168..eb1db996a27c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
# Contributor: Taylor Venable <taylor@metasyntax.net>
pkgname=ocaml-re
-pkgver=1.4.1
+pkgver=1.5.0
pkgrel=1
pkgdesc="Pure OCaml regular expressions, with support for Perl and POSIX-style strings"
arch=('i686' 'x86_64')
@@ -11,23 +12,21 @@ makedepends=('ocaml-findlib')
url="https://github.com/ocaml/ocaml-re"
license=('LGPL')
options=('!strip')
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/ocaml/ocaml-re/tar.gz/$pkgname-$pkgver)
-sha256sums=('262554309d645f4126a2a2e21e3a798d250293264fda34d6271243cc6c16e576')
+source=("https://github.com/ocaml/ocaml-re/archive/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('53322f763a8d771a68f986c9c323cab7d3afa56873c3eefa528fb92b1b511dd3')
build() {
- cd "$pkgname-$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- msg2 'Building...'
- ocaml setup.ml -configure --destdir "$pkgdir/usr/lib/ocaml"
- ocaml setup.ml -build
+ ./configure --prefix /usr
+ make
}
package() {
- cd "$pkgname-$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- msg2 'Installing...'
- mkdir -p "$pkgdir/$(ocamlfind printconf destdir)"
- OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
- ocaml setup.ml -install
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+ make install
}