summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD10
3 files changed, 28 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1d5ee96742c..a27715c309b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = ocaml-textutils
pkgdesc = Text output utilities for OCaml
- pkgver = 0.16.0
+ pkgver = 0.17.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/textutils
arch = x86_64
arch = aarch64
license = MIT
- makedepends = dune>=2.0.0
- depends = ocaml>=4.14.0
- depends = ocaml-core>=0.16.0
- depends = ocaml-core_kernel>=0.16.0
- depends = ocaml-core_unix>=0.16.0
- depends = ocaml-ppx_jane>=0.16.0
- depends = ocaml-textutils_kernel>=0.16.0
+ makedepends = dune>=3.11.0
+ depends = ocaml>=5.1.0
+ depends = ocaml-core>=0.17.0
+ depends = ocaml-core_kernel>=0.17.0
+ depends = ocaml-core_unix>=0.17.0
+ depends = ocaml-ppx_jane>=0.17.0
depends = ocaml-uutf>=1.0.2
options = !strip
- source = ocaml-textutils-0.16.0.tar.gz::https://github.com/janestreet/textutils/archive/v0.16.0.tar.gz
- sha512sums = 860448856cf99388a7c297271c59450d3ebef38fcc0826986f0add442cd633528f4e2b6a4babee567c250716e3fa9535c024550e58d0a082f6677a6378d99760
+ source = ocaml-textutils-0.17.0.tar.gz::https://github.com/janestreet/textutils/archive/v0.17.0.tar.gz
+ b2sums = e124050bb628964d1a064f8914952def2f58fd826f404a293e675c8e50eb31d198061df31a78e5c864601078c36bbad7c04400ff98d67cf51289990a7bea940f
pkgname = ocaml-textutils
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 6abe0578ad80..a8f3eaf4e982 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='textutils'
pkgname="ocaml-$_projectname"
-pkgver='0.16.0'
+pkgver='0.17.0'
pkgrel='1'
epoch='1'
pkgdesc='Text output utilities for OCaml'
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.14.0' 'ocaml-core>=0.16.0' 'ocaml-core_kernel>=0.16.0' 'ocaml-core_unix>=0.16.0' 'ocaml-ppx_jane>=0.16.0' 'ocaml-textutils_kernel>=0.16.0' 'ocaml-uutf>=1.0.2')
-makedepends=('dune>=2.0.0')
+depends=('ocaml>=5.1.0' 'ocaml-core>=0.17.0' 'ocaml-core_kernel>=0.17.0' 'ocaml-core_unix>=0.17.0' 'ocaml-ppx_jane>=0.17.0' 'ocaml-uutf>=1.0.2')
+makedepends=('dune>=3.11.0')
options=('!strip')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('860448856cf99388a7c297271c59450d3ebef38fcc0826986f0add442cd633528f4e2b6a4babee567c250716e3fa9535c024550e58d0a082f6677a6378d99760')
+b2sums=('e124050bb628964d1a064f8914952def2f58fd826f404a293e675c8e50eb31d198061df31a78e5c864601078c36bbad7c04400ff98d67cf51289990a7bea940f')
_sourcedirectory="$_projectname-$pkgver"
@@ -33,5 +33,5 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}