summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD52
4 files changed, 70 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ced661af161b..24efb01ecf84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,25 @@
pkgbase = ocaml-utop
- pkgdesc = A toplevel for OCaml that supports completion, colors, and parenthesis matching
- pkgver = 2.2.0
+ pkgdesc = Universal toplevel for OCaml
+ pkgver = 2.4.3
pkgrel = 1
- url = https://github.com/diml/utop
- arch = i686
+ url = https://github.com/ocaml-community/utop
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = BSD
- makedepends = dune
- makedepends = cppo
- depends = ocaml
- depends = ocaml-findlib
- depends = ocaml-lambda-term
- depends = ocaml-lwt
+ makedepends = cppo>=1.1.2
+ makedepends = dune>=1.0.0
+ depends = ocaml>=4.03.0
depends = ocaml-camomile
- depends = ocaml-react
+ depends = ocaml-findlib>=1.7.2
+ depends = ocaml-lambda-term>=2.0.0
+ depends = ocaml-lwt
+ depends = ocaml-react>=1.0.0
options = !strip
- source = https://github.com/diml/utop/releases/download/2.2.0/utop-2.2.0.tbz
- sha512sums = edacbd475c452de08e8d7c1697d0b624acc2f4854c200853664e1818ab9f9c26a3edc1c4d0a3b39bfc6f6be31440de6d45db8d342868a61fe36c4cbe4c7b5dab
+ source = ocaml-utop-2.4.3-1.tar.gz::https://github.com/ocaml-community/utop/archive/2.4.3.tar.gz
+ sha256sums = 3c882347d4673a20a524101cfdd724c3652dfc9a59598f7d3ef8cb2881bc1784
pkgname = ocaml-utop
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 31cb9381110c..234eebea006f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,43 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
# Contributor: wenLiangcan <boxeed at gmail dot com>
# Contributor: Taylor Venable <taylor@metasyntax.net>
-
-pkgname="ocaml-utop"
-pkgver=2.2.0
-pkgrel=1
-pkgdesc='A toplevel for OCaml that supports completion, colors, and parenthesis matching'
-arch=('i686' 'x86_64')
-url='https://github.com/diml/utop'
+_projectname='utop'
+pkgname="ocaml-$_projectname"
+pkgver='2.4.3'
+pkgrel='1'
+pkgdesc='Universal toplevel for OCaml'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/ocaml-community/$_projectname"
license=('BSD')
-depends=('ocaml' 'ocaml-findlib' 'ocaml-lambda-term' 'ocaml-lwt' 'ocaml-camomile' 'ocaml-react')
-makedepends=('dune' 'cppo')
+depends=('ocaml>=4.03.0' 'ocaml-camomile' 'ocaml-findlib>=1.7.2' 'ocaml-lambda-term>=2.0.0' 'ocaml-lwt' 'ocaml-react>=1.0.0')
+makedepends=('cppo>=1.1.2' 'dune>=1.0.0')
options=('!strip')
-source=("https://github.com/diml/utop/releases/download/${pkgver}/utop-${pkgver}.tbz")
-sha512sums=('edacbd475c452de08e8d7c1697d0b624acc2f4854c200853664e1818ab9f9c26a3edc1c4d0a3b39bfc6f6be31440de6d45db8d342868a61fe36c4cbe4c7b5dab')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('3c882347d4673a20a524101cfdd724c3652dfc9a59598f7d3ef8cb2881bc1784')
-build() {
- cd "${srcdir}/utop-${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- jbuilder build
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ sed -i "s/%%VERSION%%/$pkgver/g" 'src/lib/uTop.ml'
}
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
+}
package() {
- cd "${srcdir}/utop-${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
+
+ mv "$pkgdir/usr/man/" "$pkgdir/usr/share/man/"
- install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
- mv "${pkgdir}/usr/man" "${pkgdir}/usr/share/"
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}