summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD32
3 files changed, 44 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 698220a35548..4f898e8653bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = ocaml-zed
pkgdesc = Abstract engine for text edition in OCaml
- pkgver = 3.1.0
+ pkgver = 3.2.3
pkgrel = 2
url = https://github.com/ocaml-community/zed
arch = x86_64
- arch = i686
- arch = arm
- arch = armv6h
- arch = armv7h
arch = aarch64
- license = BSD
- makedepends = dune>=1.1.0
+ license = BSD-3-Clause
+ checkdepends = ocaml-alcotest
+ makedepends = dune>=3.0.0
depends = ocaml>=4.02.3
- depends = ocaml-camomile>=1.0.1
depends = ocaml-react
- depends = ocaml-charinfo_width>=1.1.0
+ depends = ocaml-result
+ depends = ocaml-uchar
+ depends = ocaml-uuseg
+ depends = ocaml-uucp>=2.0.0
+ depends = ocaml-uutf
options = !strip
- source = ocaml-zed-3.1.0-2.tar.gz::https://github.com/ocaml-community/zed/archive/3.1.0.tar.gz
- sha256sums = c387b0496c34c7eb680999e751525992e3e636a803297480ef004498887625fd
+ source = ocaml-zed-3.2.3.tar.gz::https://github.com/ocaml-community/zed/archive/3.2.3.tar.gz
+ sha512sums = 637f75129550f6459417549d44bed16bdc62721d2e9e0c6bb5bfab30c5bc6478de15faece8c091b56f238375cb79a7bc176375400e543120bb31d7ea626b7c5b
pkgname = ocaml-zed
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 45d934a84463..a2686b716def 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
# Contributor: wenLiangcan <boxeed at gmail dot com>
# Contributor: Taylor Venable <taylor@metasyntax.net>
_projectname='zed'
pkgname="ocaml-$_projectname"
-pkgver='3.1.0'
+pkgver='3.2.3'
pkgrel='2'
pkgdesc='Abstract engine for text edition in OCaml'
-arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+arch=('x86_64' 'aarch64')
url="https://github.com/ocaml-community/$_projectname"
-license=('BSD')
-depends=('ocaml>=4.02.3' 'ocaml-camomile>=1.0.1' 'ocaml-react' 'ocaml-charinfo_width>=1.1.0')
-makedepends=('dune>=1.1.0')
+license=('BSD-3-Clause')
+depends=('ocaml>=4.02.3' 'ocaml-react' 'ocaml-result' 'ocaml-uchar' 'ocaml-uuseg' 'ocaml-uucp>=2.0.0' 'ocaml-uutf')
+makedepends=('dune>=3.0.0')
+checkdepends=('ocaml-alcotest')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('c387b0496c34c7eb680999e751525992e3e636a803297480ef004498887625fd')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('637f75129550f6459417549d44bed16bdc62721d2e9e0c6bb5bfab30c5bc6478de15faece8c091b56f238375cb79a7bc176375400e543120bb31d7ea626b7c5b')
_sourcedirectory="$_projectname-$pkgver"
@@ -23,14 +24,19 @@ build() {
dune build --release --verbose
}
+check() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune runtest --release --verbose
+}
+
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
- install -dm755 "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
- rm -r "$pkgdir/usr/doc/"
+ for _folder in "$pkgdir/usr/share/doc/"*; do
+ mv "$_folder" "$pkgdir/usr/share/doc/ocaml-$(basename "$_folder")"
+ done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
}