summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 419f8e2fc588..997dea7419c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = ocaml-zed
pkgdesc = An abstract engine for text editing
- pkgver = 2.0.3
+ pkgver = 2.0.5
pkgrel = 1
url = https://github.com/diml/zed
arch = i686
arch = x86_64
license = BSD
makedepends = dune
+ depends = glibc
depends = ocaml
depends = ocaml-camomile
depends = ocaml-react
depends = ocaml-charinfo_width
options = !strip
- source = https://github.com/diml/zed/archive/2.0.3.tar.gz
- sha512sums = b1c790d2a0d0b6fe8d43a718716910ebb38c16a8adad553f08120dfb653da971312ce760d68efb458b662bc8c39c60c46b9c3e951f61535f7972b444f4eabdbc
+ source = zed-2.0.5.tar.gz::https://github.com/diml/zed/archive/2.0.5.tar.gz
+ sha512sums = 64b47b80dcea4d8016ce0203684511f0be9ac3adb8393e0755d847483690c6a56b2147ca217e9419de715a8513a59b821767969ceab418f11bcf30273b62724b
pkgname = ocaml-zed
diff --git a/PKGBUILD b/PKGBUILD
index d6767f36cec0..7d317f936a0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
# Contributor: Taylor Venable <taylor@metasyntax.net>
pkgname=ocaml-zed
-pkgver=2.0.3
+pkgver=2.0.5
pkgrel=1
pkgdesc="An abstract engine for text editing"
arch=('i686' 'x86_64')
url='https://github.com/diml/zed'
license=('BSD')
-depends=('ocaml' 'ocaml-camomile' 'ocaml-react' 'ocaml-charinfo_width')
+depends=('glibc' 'ocaml' 'ocaml-camomile' 'ocaml-react' 'ocaml-charinfo_width')
makedepends=('dune')
options=('!strip')
-source=("https://github.com/diml/zed/archive/${pkgver}.tar.gz")
-sha512sums=('b1c790d2a0d0b6fe8d43a718716910ebb38c16a8adad553f08120dfb653da971312ce760d68efb458b662bc8c39c60c46b9c3e951f61535f7972b444f4eabdbc')
+source=("zed-${pkgver}.tar.gz::https://github.com/diml/zed/archive/${pkgver}.tar.gz")
+sha512sums=('64b47b80dcea4d8016ce0203684511f0be9ac3adb8393e0755d847483690c6a56b2147ca217e9419de715a8513a59b821767969ceab418f11bcf30273b62724b')
build() {
cd "${srcdir}/zed-${pkgver}"
- dune build --profile release
+ dune build -p zed
}