summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--oci-cli.patch53
3 files changed, 16 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 207c42ffe1bf..c8ca211873ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.24.2
+ pkgver = 3.40.0
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
- license = Apache
+ license = Apache-2.0 OR UPL-1.0
makedepends = python-setuptools
depends = python
depends = python-oci
@@ -17,15 +17,14 @@ pkgbase = oci-cli
depends = python-jmespath
depends = python-terminaltables
depends = python-idna
+ depends = python-prompt_toolkit
depends = python-pytz
depends = python-six
depends = python-retrying
+ depends = python-wcwidth
depends = python-yaml
- optdepends = python-cx_oracle-git: Used by the database service
- source = oci-cli-2.24.2.tar.gz::https://github.com/oracle/oci-cli/archive/v2.24.2.tar.gz
- source = oci-cli.patch
- sha256sums = 0b876adfc92a9b7c40d00e7060441ff3b3e11de7c73c2a0cfb31f8869944e4be
- sha256sums = 41f61684f1939fa72a4bf4feb71da77a5f96f58a28124ac650260dac8f39b86e
+ optdepends = python-cx_oracle: Used by the database service
+ source = oci-cli-3.40.0.tar.gz::https://github.com/oracle/oci-cli/archive/v3.40.0.tar.gz
+ sha256sums = 9652c0af6adf0a440a19f2e100c29f67fd42d788483600c56ee7558d1081bd99
pkgname = oci-cli
-
diff --git a/PKGBUILD b/PKGBUILD
index 2dfdad1d41ad..96571d222851 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
-# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Maintainer: Andrew O'Neill <andrew at haunted dot sh>
pkgname=oci-cli
-pkgver=2.24.2
+pkgver=3.40.0
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
-url='https://github.com/oracle/oci-cli'
-license=('Apache')
-depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-idna' 'python-pytz' 'python-six' 'python-retrying' 'python-yaml')
+url="https://github.com/oracle/${pkgname}"
+license=('Apache-2.0 OR UPL-1.0')
+depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-idna' 'python-prompt_toolkit' 'python-pytz' 'python-six' 'python-retrying' 'python-wcwidth' 'python-yaml')
makedepends=('python-setuptools')
-optdepends=('python-cx_oracle-git: Used by the database service')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
- "${pkgname}.patch")
-sha256sums=('0b876adfc92a9b7c40d00e7060441ff3b3e11de7c73c2a0cfb31f8869944e4be'
- '41f61684f1939fa72a4bf4feb71da77a5f96f58a28124ac650260dac8f39b86e')
+optdepends=('python-cx_oracle: Used by the database service')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('9652c0af6adf0a440a19f2e100c29f67fd42d788483600c56ee7558d1081bd99')
prepare() {
cd "${pkgname}-${pkgver}"
- patch -p1 -i ../${pkgname}.patch
+ sed -i -r "s/(==|>|<).*[0-9].*'/'/g" setup.py
}
build() {
diff --git a/oci-cli.patch b/oci-cli.patch
deleted file mode 100644
index 4d74c1d88b46..000000000000
--- a/oci-cli.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -rupN oci-cli-2.24.2/setup.py oci-cli-2.24.2b/setup.py
---- oci-cli-2.24.2/setup.py 2021-04-27 19:55:25.000000000 -0400
-+++ oci-cli-2.24.2b/setup.py 2021-05-02 01:37:28.497145222 -0400
-@@ -30,24 +30,23 @@ with open_relative("README.rst") as f:
- readme = f.read()
-
- requires = [
-- 'oci==2.38.0',
-- 'arrow==0.17.0',
-+ 'oci',
-+ 'arrow',
- 'certifi',
-- 'click==6.7',
-- 'configparser==4.0.2',
-- 'cryptography==3.3.2',
-- 'jmespath==0.10.0',
-- 'python-dateutil>=2.5.3,<3.0.0',
-- 'pytz>=2016.10',
-- 'retrying==1.3.3',
-- 'six==1.14.0',
-- 'terminaltables==3.1.0',
-- 'pyOpenSSL==19.1.0',
-- 'PyYAML==5.3.1'
-+ 'click',
-+ 'cryptography',
-+ 'jmespath',
-+ 'python-dateutil',
-+ 'pytz',
-+ 'retrying',
-+ 'six',
-+ 'terminaltables',
-+ 'pyOpenSSL',
-+ 'PyYAML'
- ]
-
- extras = {
-- 'db': ['cx_Oracle==7.0']
-+ 'db': ['cx_Oracle']
- }
-
- fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.24.2/src/oci_cli/cli_root.py oci-cli-2.24.2b/src/oci_cli/cli_root.py
---- oci-cli-2.24.2/src/oci_cli/cli_root.py 2021-04-27 19:55:25.000000000 -0400
-+++ oci-cli-2.24.2b/src/oci_cli/cli_root.py 2021-05-02 01:59:25.633147095 -0400
-@@ -305,7 +305,7 @@ For information on configuration, see ht
- @click.option('--profile',
- default=Sentinel(DEFAULT_PROFILE), show_default=False,
- help='The profile in the config file to load. This profile will also be used to locate any default parameter values which have been specified in the OCI CLI-specific configuration file. [default: DEFAULT]')
--@click.option('--cli-rc-file', '--defaults-file',
-+@click.option('--cli-rc-file', '--defaults-file', 'defaults_file',
- default=cli_constants.CLI_RC_DEFAULT_LOCATION, show_default=True,
- is_eager=True, callback=eager_load_cli_rc_file,
- help='The path to the OCI CLI-specific configuration file, containing parameter default values and other configuration information such as command aliases and predefined queries. The --defaults-file option is deprecated and you should use the --cli-rc-file option instead.')