summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--oci-cli.patch14
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec34618e7db9..5e7d8c66f24f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.21.5
+ pkgver = 2.21.6
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -22,10 +22,10 @@ pkgbase = oci-cli
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = oci-cli-2.21.5.tar.gz::https://github.com/oracle/oci-cli/archive/v2.21.5.tar.gz
+ source = oci-cli-2.21.6.tar.gz::https://github.com/oracle/oci-cli/archive/v2.21.6.tar.gz
source = oci-cli.patch
- sha256sums = 9e6c47fd29835af95552131d23cbb76a1698f3d708c849a20516834f1ffcc7a9
- sha256sums = 163e1298a3aeb1d39d9bad3e862424ad357382f5ca52c4e2dc6a50054831c0f1
+ sha256sums = abeb12131a27a152cc1c2aa35d94b3597255b7f67bd9e81650e4e46917936630
+ sha256sums = 45619cf3c92838f97e81f90f80ad3a37246bb728fba3c3aadb9fbc062d4f0548
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index 588fdf693014..b63ebb1d6d82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.21.5
+pkgver=2.21.6
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -12,8 +12,8 @@ makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('9e6c47fd29835af95552131d23cbb76a1698f3d708c849a20516834f1ffcc7a9'
- '163e1298a3aeb1d39d9bad3e862424ad357382f5ca52c4e2dc6a50054831c0f1')
+sha256sums=('abeb12131a27a152cc1c2aa35d94b3597255b7f67bd9e81650e4e46917936630'
+ '45619cf3c92838f97e81f90f80ad3a37246bb728fba3c3aadb9fbc062d4f0548')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index ad7def53afc7..32fdab2b5da4 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,11 +1,11 @@
-diff -rupN oci-cli-2.21.5/setup.py oci-cli-2.21.5b/setup.py
---- oci-cli-2.21.5/setup.py 2021-03-09 14:02:51.000000000 -0500
-+++ oci-cli-2.21.5b/setup.py 2021-03-14 17:38:30.099759867 -0400
+diff -rupN oci-cli-2.21.6/setup.py oci-cli-2.21.6b/setup.py
+--- oci-cli-2.21.6/setup.py 2021-03-16 15:28:25.000000000 -0400
++++ oci-cli-2.21.6b/setup.py 2021-03-18 22:54:32.207765619 -0400
@@ -30,24 +30,23 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.32.1',
+- 'oci==2.33.0',
- 'arrow==0.17.0',
+ 'oci',
+ 'arrow',
@@ -39,9 +39,9 @@ diff -rupN oci-cli-2.21.5/setup.py oci-cli-2.21.5b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.21.5/src/oci_cli/cli_root.py oci-cli-2.21.5b/src/oci_cli/cli_root.py
---- oci-cli-2.21.5/src/oci_cli/cli_root.py 2021-03-09 14:02:51.000000000 -0500
-+++ oci-cli-2.21.5b/src/oci_cli/cli_root.py 2021-03-14 17:41:25.240244424 -0400
+diff -rupN oci-cli-2.21.6/src/oci_cli/cli_root.py oci-cli-2.21.6b/src/oci_cli/cli_root.py
+--- oci-cli-2.21.6/src/oci_cli/cli_root.py 2021-03-16 15:28:25.000000000 -0400
++++ oci-cli-2.21.6b/src/oci_cli/cli_root.py 2021-03-18 22:55:04.544607395 -0400
@@ -300,7 +300,7 @@ For information on configuration, see ht
@click.option('--profile',
default=Sentinel(DEFAULT_PROFILE), show_default=False,