summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--oci-cli.patch23
3 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 125602a4b7dc..3036f2c4cce9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.5.5
+ pkgver = 2.5.8
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -23,11 +23,11 @@ pkgbase = oci-cli
depends = python-six
depends = python-retrying
depends = python-yaml
- depends = python-cx_oracle-git
- source = https://github.com/oracle/oci-cli/archive/v2.5.5.tar.gz
+ optdepends = python-cx_oracle-git: Used by the database service
+ source = https://github.com/oracle/oci-cli/archive/v2.5.8.tar.gz
source = oci-cli.patch
- sha256sums = e15f68d96cc334151fb345d0079aa14e62ffce10b8280fd6196afaeb9fff109f
- sha256sums = 2c377ec8de55f2c4ce43332668278f989c5dc07b6ab448036c589f2d582c99f3
+ sha256sums = 488181fd28d598513a0f1dffb402bd38b807f357e27131a04acb5b351aefbcfb
+ sha256sums = c24b4cde35656a9f4c1cf10b4226f871b8710d45e2eb55b65d25d7529e1578cd
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index 7d17c72d6095..33bb61ada34f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.5.5
+pkgver=2.5.8
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
url='https://github.com/oracle/oci-cli'
license=('Apache')
-depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-httpsig_cffi' 'python-idna' 'python-pytz' 'python-requests' 'python-six' 'python-retrying' 'python-yaml' 'python-cx_oracle-git')
+depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-httpsig_cffi' 'python-idna' 'python-pytz' 'python-requests' 'python-six' 'python-retrying' 'python-yaml')
makedepends=('python-setuptools')
+optdepends=('python-cx_oracle-git: Used by the database service')
source=("${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('e15f68d96cc334151fb345d0079aa14e62ffce10b8280fd6196afaeb9fff109f'
- '2c377ec8de55f2c4ce43332668278f989c5dc07b6ab448036c589f2d582c99f3')
+sha256sums=('488181fd28d598513a0f1dffb402bd38b807f357e27131a04acb5b351aefbcfb'
+ 'c24b4cde35656a9f4c1cf10b4226f871b8710d45e2eb55b65d25d7529e1578cd')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index 11616979f638..a8b0db338ead 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,11 +1,11 @@
-diff -rupN oci-cli-2.5.5/setup.py oci-cli-2.5.5b/setup.py
---- oci-cli-2.5.5/setup.py 2019-03-26 15:20:34.000000000 -0400
-+++ oci-cli-2.5.5b/setup.py 2019-04-02 20:16:07.791609876 -0400
-@@ -29,23 +29,22 @@ with open_relative("README.rst") as f:
+diff -rupN oci-cli-2.5.8/setup.py oci-cli-2.5.8b/setup.py
+--- oci-cli-2.5.8/setup.py 2019-04-16 15:43:28.000000000 -0400
++++ oci-cli-2.5.8b/setup.py 2019-05-01 21:06:00.741767895 -0400
+@@ -29,26 +29,25 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.2.4',
+- 'oci==2.2.7',
- 'arrow==0.10.0',
+ 'oci',
+ 'arrow',
@@ -13,7 +13,6 @@ diff -rupN oci-cli-2.5.5/setup.py oci-cli-2.5.5b/setup.py
- 'click==6.7',
- 'configparser==3.5.0',
- 'cryptography==2.4.2',
-- 'cx_Oracle==7.0',
- 'httpsig_cffi==15.0.0',
- 'jmespath==0.9.3',
- 'python-dateutil==2.7.3',
@@ -26,7 +25,6 @@ diff -rupN oci-cli-2.5.5/setup.py oci-cli-2.5.5b/setup.py
- 'PyYAML==3.13'
+ 'click',
+ 'cryptography',
-+ 'cx_Oracle',
+ 'httpsig_cffi',
+ 'jmespath',
+ 'python-dateutil',
@@ -39,10 +37,15 @@ diff -rupN oci-cli-2.5.5/setup.py oci-cli-2.5.5b/setup.py
+ 'PyYAML'
]
+ extras = {
+- 'db': ['cx_Oracle==7.0']
++ 'db': ['cx_Oracle']
+ }
+
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.5.5/src/oci_cli/cli_root.py oci-cli-2.5.5b/src/oci_cli/cli_root.py
---- oci-cli-2.5.5/src/oci_cli/cli_root.py 2019-03-26 15:20:34.000000000 -0400
-+++ oci-cli-2.5.5b/src/oci_cli/cli_root.py 2019-04-02 19:58:29.881922389 -0400
+diff -rupN oci-cli-2.5.8/src/oci_cli/cli_root.py oci-cli-2.5.8b/src/oci_cli/cli_root.py
+--- oci-cli-2.5.8/src/oci_cli/cli_root.py 2019-04-16 15:43:28.000000000 -0400
++++ oci-cli-2.5.8b/src/oci_cli/cli_root.py 2019-05-01 21:06:48.868311967 -0400
@@ -197,7 +197,7 @@ For information on configuration, see ht
@click.option('--profile',
default=Sentinel(DEFAULT_PROFILE), show_default=False,