summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--oci-cli.patch16
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52c0381a362f..b46f356ab60d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.12.9
+ pkgver = 2.12.10
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -22,10 +22,10 @@ pkgbase = oci-cli
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = oci-cli-2.12.9.tar.gz::https://github.com/oracle/oci-cli/archive/v2.12.9.tar.gz
+ source = oci-cli-2.12.10.tar.gz::https://github.com/oracle/oci-cli/archive/v2.12.10.tar.gz
source = oci-cli.patch
- sha256sums = f1fa5c35ac273532edc772733786cae2d4a6b3517dfcb0cebea2ce1186b91d84
- sha256sums = 0f34a3fc511fad1026ce15490e819dec07f5b50de6f506768d7336d94747f946
+ sha256sums = f72a5d871b948aa8d05b794b65cd7081dd8c11e6c7bec37810264328738bd97d
+ sha256sums = a0d1c9f669cdfbae1a6735fefda0ed18e3f442fffce228771e11de7ca23e5d55
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index e85ad6fc03db..60638bfd8081 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.12.9
+pkgver=2.12.10
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -12,8 +12,8 @@ makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('f1fa5c35ac273532edc772733786cae2d4a6b3517dfcb0cebea2ce1186b91d84'
- '0f34a3fc511fad1026ce15490e819dec07f5b50de6f506768d7336d94747f946')
+sha256sums=('f72a5d871b948aa8d05b794b65cd7081dd8c11e6c7bec37810264328738bd97d'
+ 'a0d1c9f669cdfbae1a6735fefda0ed18e3f442fffce228771e11de7ca23e5d55')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index 918ff6ed0526..738271feaacc 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,11 +1,11 @@
-diff -rupN oci-cli-2.12.9/setup.py oci-cli-2.12.9b/setup.py
---- oci-cli-2.12.9/setup.py 2020-09-01 14:44:10.000000000 -0400
-+++ oci-cli-2.12.9b/setup.py 2020-09-02 19:54:13.527968891 -0400
+diff -rupN oci-cli-2.12.10/setup.py oci-cli-2.12.10b/setup.py
+--- oci-cli-2.12.10/setup.py 2020-09-08 17:07:04.000000000 -0400
++++ oci-cli-2.12.10b/setup.py 2020-09-08 20:07:50.057207177 -0400
@@ -30,24 +30,23 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.21.2',
+- 'oci==2.21.3',
- 'arrow==0.14.7',
+ 'oci',
+ 'arrow',
@@ -39,10 +39,10 @@ diff -rupN oci-cli-2.12.9/setup.py oci-cli-2.12.9b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.12.9/src/oci_cli/cli_root.py oci-cli-2.12.9b/src/oci_cli/cli_root.py
---- oci-cli-2.12.9/src/oci_cli/cli_root.py 2020-09-01 14:44:10.000000000 -0400
-+++ oci-cli-2.12.9b/src/oci_cli/cli_root.py 2020-09-02 19:55:23.467781552 -0400
-@@ -297,7 +297,7 @@ For information on configuration, see ht
+diff -rupN oci-cli-2.12.10/src/oci_cli/cli_root.py oci-cli-2.12.10b/src/oci_cli/cli_root.py
+--- oci-cli-2.12.10/src/oci_cli/cli_root.py 2020-09-08 17:07:04.000000000 -0400
++++ oci-cli-2.12.10b/src/oci_cli/cli_root.py 2020-09-08 20:09:54.375484257 -0400
+@@ -299,7 +299,7 @@ For information on configuration, see ht
@click.option('--profile',
default=Sentinel(DEFAULT_PROFILE), show_default=False,
help='The profile in the config file to load. This profile will also be used to locate any default parameter values which have been specified in the OCI CLI-specific configuration file. [default: DEFAULT]')