summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--oci-cli.patch18
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffeae6cd68ef..66fd56123b36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.10.0
+ pkgver = 2.10.1
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -22,10 +22,10 @@ pkgbase = oci-cli
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = oci-cli-2.10.0.tar.gz::https://github.com/oracle/oci-cli/archive/v2.10.0.tar.gz
+ source = oci-cli-2.10.1.tar.gz::https://github.com/oracle/oci-cli/archive/v2.10.1.tar.gz
source = oci-cli.patch
- sha256sums = 01c017cfd2f5f57910327865accdb6148e34f9d2687df59990fef594926b9430
- sha256sums = 6bdb5420be31e51a1a4a0c1422c652a4d11676c4b8fd8ab6806200ec3bcf8228
+ sha256sums = 0922e4c5b44412d99c94b4f8c85b317d378dfef931aa56e06afb4ff59b3167b5
+ sha256sums = 0490af4080e993125d05416cd0c6e38c369b33e6a2e3f7427226cd80a56b8bad
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index be9052907915..607cfc34f5f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.10.0
+pkgver=2.10.1
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -12,8 +12,8 @@ makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('01c017cfd2f5f57910327865accdb6148e34f9d2687df59990fef594926b9430'
- '6bdb5420be31e51a1a4a0c1422c652a4d11676c4b8fd8ab6806200ec3bcf8228')
+sha256sums=('0922e4c5b44412d99c94b4f8c85b317d378dfef931aa56e06afb4ff59b3167b5'
+ '0490af4080e993125d05416cd0c6e38c369b33e6a2e3f7427226cd80a56b8bad')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index 04ee66966692..a85f086d6648 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,11 +1,11 @@
-diff -rupN oci-cli-2.10.0/setup.py oci-cli-2.10.0b/setup.py
---- oci-cli-2.10.0/setup.py 2020-04-21 18:11:13.000000000 -0400
-+++ oci-cli-2.10.0b/setup.py 2020-04-21 20:48:49.327595548 -0400
-@@ -29,25 +29,24 @@ with open_relative("README.rst") as f:
+diff -rupN oci-cli-2.10.1/setup.py oci-cli-2.10.1b/setup.py
+--- oci-cli-2.10.1/setup.py 2020-04-28 16:12:05.000000000 -0400
++++ oci-cli-2.10.1b/setup.py 2020-05-01 18:59:18.058192794 -0400
+@@ -30,25 +30,24 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.13.0',
+- 'oci==2.14.0',
- 'arrow==0.14.7',
+ 'oci',
+ 'arrow',
@@ -41,10 +41,10 @@ diff -rupN oci-cli-2.10.0/setup.py oci-cli-2.10.0b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.10.0/src/oci_cli/cli_root.py oci-cli-2.10.0b/src/oci_cli/cli_root.py
---- oci-cli-2.10.0/src/oci_cli/cli_root.py 2020-04-21 18:11:13.000000000 -0400
-+++ oci-cli-2.10.0b/src/oci_cli/cli_root.py 2020-04-21 20:49:14.380978793 -0400
-@@ -217,7 +217,7 @@ For information on configuration, see ht
+diff -rupN oci-cli-2.10.1/src/oci_cli/cli_root.py oci-cli-2.10.1b/src/oci_cli/cli_root.py
+--- oci-cli-2.10.1/src/oci_cli/cli_root.py 2020-04-28 16:12:05.000000000 -0400
++++ oci-cli-2.10.1b/src/oci_cli/cli_root.py 2020-05-01 18:58:55.355211408 -0400
+@@ -218,7 +218,7 @@ For information on configuration, see ht
@click.option('--profile',
default=Sentinel(DEFAULT_PROFILE), show_default=False,
help='The profile in the config file to load. This profile will also be used to locate any default parameter values which have been specified in the OCI CLI-specific configuration file. [default: DEFAULT]')