summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--oci-cli.patch14
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd38239729b0..8b28a0a876f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.7.0
+ pkgver = 2.8.0
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -22,10 +22,10 @@ pkgbase = oci-cli
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = https://github.com/oracle/oci-cli/archive/v2.7.0.tar.gz
+ source = oci-cli-2.8.0.tar.gz::https://github.com/oracle/oci-cli/archive/v2.8.0.tar.gz
source = oci-cli.patch
- sha256sums = 582697f77af28134a8a83b35704041be8e5e465980b95d51e25f09600958b6c4
- sha256sums = 1381e784bff7da6d19d7820c5a0c16a707dfe8d3f290faae7e19539470727d30
+ sha256sums = 6e09b0eb8c540e76c978c80a095f4ddd4d3749bd0faa23d29b4bcee6cf0741d4
+ sha256sums = 07ed8ece4663fcde36196d20cfcb11b7ffa9997931ec553c9cb2b5c77dbc8e07
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index f47dba631412..e3a857bcc3ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.7.0
+pkgver=2.8.0
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -10,10 +10,10 @@ license=('Apache')
depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-idna' 'python-pytz' 'python-six' 'python-retrying' 'python-yaml')
makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
-source=("${url}/archive/v${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('582697f77af28134a8a83b35704041be8e5e465980b95d51e25f09600958b6c4'
- '1381e784bff7da6d19d7820c5a0c16a707dfe8d3f290faae7e19539470727d30')
+sha256sums=('6e09b0eb8c540e76c978c80a095f4ddd4d3749bd0faa23d29b4bcee6cf0741d4'
+ '07ed8ece4663fcde36196d20cfcb11b7ffa9997931ec553c9cb2b5c77dbc8e07')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index 22d4c5dbce2f..ff5c307fb3fa 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,11 +1,11 @@
-diff -rupN oci-cli-2.7.0/setup.py oci-cli-2.7.0b/setup.py
---- oci-cli-2.7.0/setup.py 2019-12-17 17:36:23.000000000 -0500
-+++ oci-cli-2.7.0b/setup.py 2019-12-22 23:14:43.067307771 -0500
+diff -rupN oci-cli-2.8.0/setup.py oci-cli-2.8.0b/setup.py
+--- oci-cli-2.8.0/setup.py 2020-01-08 18:10:14.000000000 -0500
++++ oci-cli-2.8.0b/setup.py 2020-01-11 11:21:52.991914895 -0500
@@ -29,25 +29,24 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.8.0',
+- 'oci==2.9.0',
- 'arrow==0.10.0',
+ 'oci',
+ 'arrow',
@@ -41,9 +41,9 @@ diff -rupN oci-cli-2.7.0/setup.py oci-cli-2.7.0b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.7.0/src/oci_cli/cli_root.py oci-cli-2.7.0b/src/oci_cli/cli_root.py
---- oci-cli-2.7.0/src/oci_cli/cli_root.py 2019-12-17 17:36:23.000000000 -0500
-+++ oci-cli-2.7.0b/src/oci_cli/cli_root.py 2019-12-22 23:15:30.747147899 -0500
+diff -rupN oci-cli-2.8.0/src/oci_cli/cli_root.py oci-cli-2.8.0b/src/oci_cli/cli_root.py
+--- oci-cli-2.8.0/src/oci_cli/cli_root.py 2020-01-08 18:10:14.000000000 -0500
++++ oci-cli-2.8.0b/src/oci_cli/cli_root.py 2020-01-11 11:22:34.442262002 -0500
@@ -219,7 +219,7 @@ For information on configuration, see ht
@click.option('--profile',
default=Sentinel(DEFAULT_PROFILE), show_default=False,