summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--octave-image.install8
3 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f3dee8e94b9..4c56babb1135 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Oct 5 13:16:58 UTC 2016
pkgbase = octave-image
pkgdesc = The Octave-forge Image package provides functions for processing images. The package also provides functions for feature extraction, image statistics, spatial and geometric transformations, morphological operations, linear filtering, and much more.
- pkgver = 2.4.1
+ pkgver = 2.6.0
pkgrel = 1
url = http://octave.sourceforge.net/image/
install = octave-image.install
@@ -8,9 +10,9 @@ pkgbase = octave-image
groups = octave-forge
license = custom
depends = octave>=4.0.0
- noextract = image-2.4.1.tar.gz
- source = http://downloads.sourceforge.net/octave/image-2.4.1.tar.gz
- md5sums = ec07f0c9daf824e908881d95a65fbe82
+ noextract = image-2.6.0.tar.gz
+ source = http://downloads.sourceforge.net/octave/image-2.6.0.tar.gz
+ md5sums = 493621de06fe25ccb48901d762164d9c
pkgname = octave-image
diff --git a/PKGBUILD b/PKGBUILD
index 7984464bfe42..6f6784873ee8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_pack=image
pkgname=octave-$_pack
-pkgver=2.4.1
+pkgver=2.6.0
pkgrel=1
pkgdesc="The Octave-forge Image package provides functions for processing images. The package also provides functions for feature extraction, image statistics, spatial and geometric transformations, morphological operations, linear filtering, and much more."
arch=(any)
@@ -26,7 +26,11 @@ install=$pkgname.install
_archive=$_pack-$pkgver.tar.gz
source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
-md5sums=('ec07f0c9daf824e908881d95a65fbe82')
+md5sums=('493621de06fe25ccb48901d762164d9c')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
_install_dir() {
src=$1
@@ -40,7 +44,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-image.install b/octave-image.install
index 7c9ea5667f44..f86e8d16cb58 100644
--- a/octave-image.install
+++ b/octave-image.install
@@ -1,7 +1,11 @@
_pack=image
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}