summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--octave-tsa.install8
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87b6aa07e350..f317cee08078 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octave-tsa
pkgdesc = Stochastic concepts and maximum entropy methods for time series analysis
pkgver = 4.3.2
- pkgrel = 1
+ pkgrel = 2
url = http://octave.sourceforge.net/tsa/
install = octave-tsa.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 45115b859583..d36f6dd39d69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_pack=tsa
pkgname=octave-$_pack
pkgver=4.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="Stochastic concepts and maximum entropy methods for time series analysis"
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -27,6 +27,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('8aaddde1714576c15872cb0997eefaa6')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -39,7 +43,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave-cli -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-tsa.install b/octave-tsa.install
index 3f658487d315..0c9041ec0275 100644
--- a/octave-tsa.install
+++ b/octave-tsa.install
@@ -1,7 +1,11 @@
_pack=tsa
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave-cli -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave-cli -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}