summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--PKGBUILD-2.2.026
-rw-r--r--PKGBUILD-2.3.126
4 files changed, 10 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bef04ba58b8..13d77b2bb630 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octetos-core
pkgdesc = C/C++ library to mainly provide Semantic Versioned inplmetation
- pkgver = 2.3.3
- pkgrel = 2
+ pkgver = 2.5.0
+ pkgrel = 1
url = https://github.com/azaeldevel/octetos-core.git
arch = x86_64
license = GPL
@@ -10,8 +10,8 @@ pkgbase = octetos-core
depends = libconfig
depends = perl-xml-parser
depends = intltool
- source = https://github.com/azaeldevel/octetos-core/archive/2.3.3-beta.tar.gz
- md5sums = 123c69ecf4ab034be8dced45fa9c3af1
+ source = https://github.com/azaeldevel/octetos-core/archive/2.5.0-alpha.tar.gz
+ md5sums = c85028bac2a68bc415a0210a33fa3d3e
pkgname = octetos-core
diff --git a/PKGBUILD b/PKGBUILD
index 73674a5d0c0e..5443b9ad57c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,25 @@
pkgname=octetos-core
-pkgver=2.3.3
-pkgrel=2
+pkgver=2.5.0
+pkgrel=1
pkgdesc="C/C++ library to mainly provide Semantic Versioned inplmetation"
arch=('x86_64')
license=('GPL')
url="https://github.com/azaeldevel/octetos-core.git"
depends=('gcc' 'bison' 'libconfig' 'perl-xml-parser' 'intltool')
#backup=('etc/nanorc')
-md5sums=('123c69ecf4ab034be8dced45fa9c3af1')
-source=(https://github.com/azaeldevel/octetos-core/archive/2.3.3-beta.tar.gz)
+md5sums=('c85028bac2a68bc415a0210a33fa3d3e')
+source=(https://github.com/azaeldevel/octetos-core/archive/2.5.0-alpha.tar.gz)
build() {
- cd octetos-core-2.3.3-beta
+ cd octetos-core-2.5.0-alpha
autoreconf -fi
./configure --prefix=/usr --sysconfdir=/etc
make
}
package() {
- cd octetos-core-2.3.3-beta
+ cd octetos-core-2.5.0-alpha
make DESTDIR="${pkgdir}" install
}
diff --git a/PKGBUILD-2.2.0 b/PKGBUILD-2.2.0
deleted file mode 100644
index 2050279331fb..000000000000
--- a/PKGBUILD-2.2.0
+++ /dev/null
@@ -1,26 +0,0 @@
-# Maintainer: Azael Reyes <azael.devel@gmail.com>
-
-
-pkgname=octetos-core
-pkgver=2.2.0
-pkgrel=1
-pkgdesc="C/C++ library to mainly provide Semantic Versioned inplmetation"
-arch=('x86_64')
-license=('GPL')
-url="https://github.com/azaeldevel/octetos-core.git"
-depends=('bison' 'libconfig' 'intltool')
-#backup=('etc/nanorc')
-md5sums=('952853ca87cbf5ddd888aec14138c0d7')
-source=(https://github.com/azaeldevel/octetos-core/archive/2.2.0-beta.3.tar.gz)
-
-build() {
- cd octetos-core-2.2.0-beta.3
- autoreconf -fi
- ./configure --prefix=/usr --sysconfdir=/etc
- make
-}
-
-package() {
- cd octetos-core-2.2.0-beta.3
- make DESTDIR="${pkgdir}" install
-}
diff --git a/PKGBUILD-2.3.1 b/PKGBUILD-2.3.1
deleted file mode 100644
index 9a58cbb066e4..000000000000
--- a/PKGBUILD-2.3.1
+++ /dev/null
@@ -1,26 +0,0 @@
-# Maintainer: Azael Reyes <azael.devel@gmail.com>
-
-
-pkgname=octetos-core
-pkgver=2.3.1
-pkgrel=2
-pkgdesc="C/C++ library to mainly provide Semantic Versioned inplmetation"
-arch=('x86_64')
-license=('GPL')
-url="https://github.com/azaeldevel/octetos-core.git"
-depends=('gcc' 'bison' 'libconfig' 'perl-xml-parser' 'intltool')
-#backup=('etc/nanorc')
-md5sums=('5eccd80fdadde558d9d93be996154901')
-source=(https://github.com/azaeldevel/octetos-core/archive/2.3.1-beta.1.tar.gz)
-
-build() {
- cd octetos-core-2.3.1-beta.1
- autoreconf -fi
- ./configure --prefix=/usr --sysconfdir=/etc
- make
-}
-
-package() {
- cd octetos-core-2.3.1-beta.1
- make DESTDIR="${pkgdir}" install
-}