summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
-rw-r--r--octopi.install12
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68f310a0b6ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = octopi-notifier-noknotify
+ pkgdesc = Notifier for Octopi without knotify
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/aarnt/octopi
+ install = octopi.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = qt5-declarative
+ makedepends = libnotify
+ depends = octopi
+ depends = libnotify
+ optdepends = xfce4-notifyd: for notifications in XFCE
+ conflicts = octopi-notifier-qt4
+ conflicts = octopi-notifier-kde
+ conflicts = octopi-notifier-kde4
+ conflicts = octopi-notifier
+ source = https://github.com/aarnt/octopi/archive/v0.8.0.tar.gz
+ sha256sums = 79ab8a24e3329ab4e5320e03309f44f802336cc00bada0f9a37fae46f5eeb02b
+
+pkgname = octopi-notifier-noknotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bc33ae5e37e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=octopi-notifier-noknotify
+pkgdesc="Notifier for Octopi without knotify"
+pkgver=0.8.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/aarnt/octopi"
+license=('GPL2')
+conflicts=('octopi-notifier-qt4' 'octopi-notifier-kde' 'octopi-notifier-kde4' 'octopi-notifier')
+depends=('octopi' 'libnotify')
+makedepends=('qt5-declarative' 'libnotify')
+optdepends=('xfce4-notifyd: for notifications in XFCE')
+source=("https://github.com/aarnt/octopi/archive/v${pkgver}.tar.gz")
+install=octopi.install
+sha256sums=('79ab8a24e3329ab4e5320e03309f44f802336cc00bada0f9a37fae46f5eeb02b')
+
+prepare() {
+ _cpucount=$(grep -c processor /proc/cpuinfo 2>/dev/null)
+ _jc=$((${_cpucount:-1}))
+
+ cd "${srcdir}/octopi-${pkgver}"
+}
+
+build() {
+ cd "${srcdir}/octopi-${pkgver}"
+
+ qmake-qt5 octopi.pro
+ make -j $_jc
+
+ cd "${srcdir}/octopi-${pkgver}/notifier/octopi-notifier"
+ msg "Building octopi-notifier..."
+ qmake-qt5 octopi-notifier.pro
+ make -j $_jc
+}
+
+package() {
+ cd "${srcdir}/octopi-${pkgver}"
+
+ install -D -m755 "${srcdir}/octopi-${pkgver}/notifier/bin/octopi-notifier" "${pkgdir}/usr/bin/octopi-notifier"
+ install -D -m644 "${srcdir}/octopi-${pkgver}/octopi-notifier.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${srcdir}/octopi-${pkgver}/octopi-notifier.desktop" "${pkgdir}/etc/xdg/autostart/${pkgname}.desktop"
+}
+
+# vim: set ts=2 sw=2 ft=sh noet:
diff --git a/octopi.install b/octopi.install
new file mode 100644
index 000000000000..8ec315e7c2ac
--- /dev/null
+++ b/octopi.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}