summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
2 files changed, 29 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a11636f62c99..45122c9c60ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = octopi-notifier-qt5
pkgdesc = Notifier for Octopi using Qt5 libs
- pkgver = 0.9.0
- pkgrel = 19
- url = http://octopiproject.wordpress.com
- arch = i686
- arch = x86_64
+ pkgver = 0.15.0
+ pkgrel = 3
+ url = https://tintaescura.com/projects/octopi/
+ arch = any
license = GPL2
makedepends = qt5-tools
- depends = octopi-dev
- depends = libnotify
+ depends = octopi
optdepends = xfce4-notifyd: for notifications in XFCE
provides = octopi-notifier
- conflicts = octopi-notifier-frameworks
- source = octopi-0.9.0-19.tar.gz::https://github.com/aarnt/octopi/archive/fd5dcc07fa7271e14636074d6136819cf5a59c3b.tar.gz
- sha256sums = fe0dbd875c423b11890bd19d88d273c72dcbe734ee0737ab7b25e4b380b0b42f
+ source = octopi::https://github.com/aarnt/octopi/archive/refs/tags/v0.15.0.tar.gz
+ sha256sums = e94525d906d6ab4f5fc594cf1a267668ae5f1fa7f32e449ddfa84328dd738f30
pkgname = octopi-notifier-qt5
-
diff --git a/PKGBUILD b/PKGBUILD
index ddc2693d2bca..c8c93b4df45d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,34 @@
-# Maintainer: MatMoul <matmoul@gmail.com>
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
-_pkggit=octopi
-_gitcommit=fd5dcc07fa7271e14636074d6136819cf5a59c3b
-_gitsha256='fe0dbd875c423b11890bd19d88d273c72dcbe734ee0737ab7b25e4b380b0b42f'
+_githubuser=aarnt
+_githubrepo=octopi
+_pkgtagname=v0.15.0
-pkgbase=octopi-notifier-qt5
-pkgname=('octopi-notifier-qt5')
-pkgver=0.9.0
-pkgrel=19
-pkgdesc="Notifier for Octopi using Qt5 libs"
-arch=('i686' 'x86_64')
-url="http://octopiproject.wordpress.com"
+pkgname=octopi-notifier-qt5
+pkgver=0.15.0
+pkgrel=3
+pkgdesc='Notifier for Octopi using Qt5 libs'
+arch=('any')
+url="https://tintaescura.com/projects/octopi/"
license=('GPL2')
-depends=("octopi-dev" 'libnotify')
+#depends=('octopi' 'knotifications')
+depends=('octopi')
makedepends=('qt5-tools')
optdepends=('xfce4-notifyd: for notifications in XFCE')
provides=('octopi-notifier')
-conflicts=('octopi-notifier-frameworks')
-source=("octopi-${pkgver}-${pkgrel}.tar.gz::https://github.com/aarnt/octopi/archive/${_gitcommit}.tar.gz")
-sha256sums=(${_gitsha256})
-
-prepare() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-}
+source=("${_githubrepo}::https://github.com/${_githubuser}/${_githubrepo}/archive/refs/tags/${_pkgtagname}.tar.gz")
+sha256sums=('e94525d906d6ab4f5fc594cf1a267668ae5f1fa7f32e449ddfa84328dd738f30')
build() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- msg "Building octopi-notifier..."
- cd notifier
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro
- make
+ cd "${_githubrepo}-${pkgver}"
+ msg "Building octopi-notifier..."
+ cd notifier
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro
+ make
}
package() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- cd notifier
- make INSTALL_ROOT="${pkgdir}" install
+ cd "${_githubrepo}-${pkgver}"
+ cd notifier
+ make INSTALL_ROOT="${pkgdir}" install
}