summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13b465dc0002
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Aug 10 21:08:13 UTC 2016
+pkgbase = odhcp6c-git
+ pkgdesc = minimal DHCPv6 and RA-client for use in embedded Linux systems
+ pkgver = v1.1.r54.g7533a62
+ pkgrel = 1
+ url = https://wiki.openwrt.org/doc/techref/odhcp6c
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ provides = odhcp6c
+ conflicts = odhcp6c
+ source = odhcp6c::git+https://github.com/sbyx/odhcp6c
+ md5sums = SKIP
+
+pkgname = odhcp6c-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2a4369f225d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Lightning <sgsdxzy@gmail.com>
+
+pkgname=odhcp6c-git
+pkgver=v1.1.r54.g7533a62
+pkgrel=1
+pkgdesc='minimal DHCPv6 and RA-client for use in embedded Linux systems'
+arch=('x86_64' 'i686')
+url='https://wiki.openwrt.org/doc/techref/odhcp6c'
+license=('GPL2')
+makedepends=('cmake' 'git')
+provides=('odhcp6c')
+conflicts=('odhcp6c')
+source=('odhcp6c::git+https://github.com/sbyx/odhcp6c')
+md5sums=('SKIP')
+
+pkgver() {
+ cd odhcp6c
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p odhcp6c/build
+}
+
+build() {
+ cd odhcp6c/build
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd odhcp6c/build
+ make DESTDIR="$pkgdir/" install
+ mv "$pkgdir/usr/sbin" "$pkgdir/usr/bin"
+}
+
+# vim: ts=2 sw=2 et: