summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fix-lv2-include.patch13
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 507196256eb1..9a160f1ce23f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = odin2-synthesizer
pkgdesc = 24 voice polyphonic synthesizer, with modulation and FX. (Standalone, VST3, LV2, CLAP)
pkgver = 2.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.thewavewarden.com/odin2
install = .install
arch = x86_64
@@ -24,6 +24,8 @@ pkgbase = odin2-synthesizer
backup = opt/odin2/Soundbanks/User Patches
source = git+https://github.com/TheWaveWarden/odin2.git
source = add-missing-include.patch
+ source = fix-lv2-include.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 111e60d94979..c25f4eb3654d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=odin2-synthesizer
pkgver=2.3.3
-pkgrel=1
+pkgrel=2
pkgdesc='24 voice polyphonic synthesizer, with modulation and FX. (Standalone, VST3, LV2, CLAP)'
license=('GPL3')
arch=('x86_64')
@@ -25,8 +25,9 @@ optdepends=('ttf-dejavu: One of these may be needed for fonts to render correctl
source=(
"git+https://github.com/TheWaveWarden/odin2.git"
- "add-missing-include.patch")
-sha256sums=('SKIP' 'SKIP')
+ "add-missing-include.patch"
+ "fix-lv2-include.patch")
+sha256sums=('SKIP' 'SKIP' 'SKIP')
backup=('opt/odin2/odin2.conf' 'opt/odin2/Soundbanks/User Patches')
install='.install'
@@ -35,9 +36,10 @@ prepare() {
# Checkout the correct branch and generate the build files
cd "${srcdir}/odin2"
git checkout -q v2.3.3
- git submodule update --init --recursive
+ git submodule update --init --recursive --progress
cd "${srcdir}/odin2/libs/JUCELV2"
git apply "${srcdir}/add-missing-include.patch"
+ git apply "${srcdir}/fix-lv2-include.patch"
cd "${srcdir}/odin2"
cmake -B build -D CMAKE_BUILD_TYPE=Release
}
diff --git a/fix-lv2-include.patch b/fix-lv2-include.patch
new file mode 100644
index 000000000000..b70fe48d533d
--- /dev/null
+++ b/fix-lv2-include.patch
@@ -0,0 +1,13 @@
+diff --git a/modules/juce_audio_plugin_client/LV2/includes/lv2_programs.h b/modules/juce_audio_plugin_client/LV2/includes/lv2_programs.h
+index 40d5ef767..0e2997dfd 100644
+--- a/modules/juce_audio_plugin_client/LV2/includes/lv2_programs.h
++++ b/modules/juce_audio_plugin_client/LV2/includes/lv2_programs.h
+@@ -23,7 +23,7 @@
+ #ifndef LV2_PROGRAMS_H
+ #define LV2_PROGRAMS_H
+
+-#include "lv2.h"
++#include "lv2/lv2plug.in/ns/lv2core/lv2.h"
+ #include "lv2/lv2plug.in/ns/extensions/ui/ui.h"
+
+ #define LV2_PROGRAMS_URI "http://kxstudio.sf.net/ns/lv2ext/programs"