summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--ohsnap.install20
3 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 241815befb7a..ab9166b63b9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ohsnap-otb
pkgdesc = Monospaced font based on Artwiz Snap (OTB version)
pkgver = 1.8.0
- pkgrel = 2
+ pkgrel = 3
url = https://sourceforge.net/projects/osnapfont
arch = any
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 9d5ca6a34dc3..edf20653ddb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ohsnap-otb
pkgver=1.8.0
-pkgrel=2
+pkgrel=3
pkgdesc="Monospaced font based on Artwiz Snap (OTB version)"
url="https://sourceforge.net/projects/osnapfont"
arch=('any')
diff --git a/ohsnap.install b/ohsnap.install
new file mode 100644
index 000000000000..365fd902c279
--- /dev/null
+++ b/ohsnap.install
@@ -0,0 +1,20 @@
+# arg 1: the new package version
+post_install() {
+ echo "Updating font cache... "
+ fc-cache -fs >/dev/null 2>&1
+ mkfontscale /usr/share/fonts/local
+ mkfontdir /usr/share/fonts/local
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+post_remove() {
+ fc-cache -fs >/dev/null 2>&1
+ mkfontscale /usr/share/fonts/local
+ mkfontdir /usr/share/fonts/local
+}