summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45246967440c..88860a5a95cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,7 @@
+# Generated by mksrcinfo v8
+# Mon Jun 5 03:49:04 UTC 2017
pkgbase = oki-b411-b431
- pkgdesc = cups driver for the Okidata B411 and B431
+ pkgdesc = CUPS printer driver for the Okidata B411 and B431
pkgver = 5.0.0
pkgrel = 1
url = http://www.okidata.com/
diff --git a/PKGBUILD b/PKGBUILD
index 3ce9762ef9b9..68af3e247c60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,36 @@
# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
# Category: system
-# Recommended build & install command: makepkg -scCfi
-
set -u
pkgname='oki-b411-b431'
_pkgnick='MB400PCL'
pkgver='5.0.0'
-pkgrel=1
-pkgdesc='cups driver for the Okidata B411 and B431'
-url='http://www.okidata.com/'
+pkgrel='1'
+pkgdesc='CUPS printer driver for the Okidata B411 and B431'
arch=('i686' 'x86_64')
+url='http://www.okidata.com/'
license=('GPL')
depends=('cups')
# install="${pkgname}.install"
-# An install is not necessary. Printers appear and disappear from cups
+# An Install is not necessary. Printers appear and disappear from cups
# without a systemctl reload org.cups.cupsd.service or killall -HUP cupsd
source=('ftp://ftp2.okidata.com/pub/drivers/linux/SFP/monochrome/desktop/MB400PCLv5.tar')
sha256sums=('3ab2df56a62e03d0c0f8dcbb09ea7cde757eac3eb9ab1772f5f3c421cbb6c73f')
prepare() {
set -u
- #cd "${pkgname}-${pkgver}"
cd "${_pkgnick}"
# There's 101 ways to hack up this installer. I choose to
# fix it the way it should be for most package makers.
- chmod 755 install.sh
- sed -i -e 's:^\(_CUPS[A-Z]*="\):# \1:g' \
- -e 's:PATH="\(/usr/\):PATH="${DESTDIR}\1:g' \
- -e 's:^\(for i in \${_CUPS}\):if [ "${DESTDIR}" != "" ]; then\n\texit 0\nfi\n\n\1:g' \
- -e 's:\(\${CHOWN}\):# \1:g' \
- -e 's:\(\${CHGRP}\):true # \1:g' \
- -e 's:^\(PATH=/\):# \1:g' \
- -e 's:^\(export PATH\):# \1:g' \
- -e 's:^if \[ \(`${ID} -u`\):if \[ "${DESTDIR}" = "" -a \1:g' 'install.sh'
+ chmod 755 'install.sh'
+ sed -e 's:^\(_CUPS[A-Z]*="\):# \1:g' \
+ -e 's:PATH="\(/usr/\):PATH="${DESTDIR}\1:g' \
+ -e 's:^\(for i in \${_CUPS}\):if [ "${DESTDIR}" != "" ]; then\n\texit 0\nfi\n\n\1:g' \
+ -e 's:\(\${CHOWN}\):# \1:g' \
+ -e 's:\(\${CHGRP}\):true # \1:g' \
+ -e 's:^\(PATH=/\):# \1:g' \
+ -e 's:^\(export PATH\):# \1:g' \
+ -e 's:^if \[ \(`${ID} -u`\):if \[ "${DESTDIR}" = "" -a \1:g' -i 'install.sh'
set +u
}
@@ -42,7 +39,8 @@ package() {
cd "${_pkgnick}"
install -d "${pkgdir}/usr/share/cups/model"
install -d "${pkgdir}/usr/lib/cups/filter"
- sh -c "export DESTDIR='${pkgdir}'; ./install.sh"
+ DESTDIR="${pkgdir}" \
+ sh -u -e 'install.sh'
set +u
}
set +u