summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efb22c9219b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = olive-community-effects-git
+ pkgdesc = A collection of effects for Olive made by the community
+ pkgver = r34.fe15bf9
+ pkgrel = 1
+ url = https://github.com/cgvirus/Olive-Editor-Community-Effects
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = olive-git
+ conflicts = olive
+ source = git+https://github.com/cgvirus/Olive-Editor-Community-Effects#commit=fe15bf9
+ sha512sums = SKIP
+
+pkgname = olive-community-effects-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..009a3ac23129
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=olive-community-effects-git
+_pkgname=Olive-Editor-Community-Effects
+pkgver=r34.fe15bf9
+_commit=fe15bf9
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="A collection of effects for Olive made by the community"
+url="https://github.com/cgvirus/Olive-Editor-Community-Effects"
+license=('unknown')
+depends=('olive-git')
+makedepends=('git')
+conflicts=('olive')
+source=("git+https://github.com/cgvirus/$_pkgname#commit=$_commit")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/olive-editor/effects/$_pkgname"
+ cp -r --preserve=mode,timestamps \
+ $srcdir/$_pkgname/* \
+ $pkgdir/usr/share/olive-editor/effects/$_pkgname/
+}