summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD40
-rw-r--r--ombi.install14
-rw-r--r--ombi.service16
-rw-r--r--ombi.sysusers1
5 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6894fb59118
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = ombi-dev
+ pkgdesc = Ombi V3 Develop branch. Gives Plex or Emby users the ability to request content by themselves
+ pkgver = 3.0.2980
+ pkgrel = 1
+ url = https://www.ombi.io
+ install = ombi.install
+ arch = any
+ license = GPL2
+ makedepends = tar
+ depends = libunwind
+ optdepends = sonarr
+ optdepends = radarr
+ optdepends = plex-media-server
+ optdepends = emby-server
+ provides = ombi
+ conflicts = ombi
+ replaces = plexrequests
+ replaces = ombi-beta
+ noextract = ombi-dev.tar.gz
+ options = staticlibs
+ backup = opt/Ombi/Ombi.sqlite
+ source = ombi-dev.tar.gz::https://ci.appveyor.com/api/projects/tidusjar/requestplex/artifacts/linux.tar.gz
+ source = ombi.service
+ source = ombi.sysusers
+ sha256sums = c29353ff9b608a869a286190ba4c7f28fb51623e9998ee62ca715f5cacdae09a
+ sha256sums = 601f9ba604c6767722397db977a9d73e800127d4a33c5511439e112d22660eba
+ sha256sums = 480941bb5c96b9e6a155d6feca16f56c74d7f13a49fc94f36132a548bd53dc0a
+
+pkgname = ombi-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f929045d79d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Nicola Hinssen <nicola.hinssen@gmail.com>
+# Contributor: Rowan Decker <rdecker@scu.edu>
+# Contributor: Donald Webster <fryfrog@gmail.com>
+# Contributor: Zack Baldwin <zack@zackb.com>
+
+pkgname=ombi-dev
+pkgver=3.0.2980
+pkgrel=1
+pkgdesc="Ombi V3 Develop branch. Gives Plex or Emby users the ability to request content by themselves"
+arch=('any')
+url='https://www.ombi.io'
+license=('GPL2')
+depends=('libunwind')
+makedepends=('tar')
+optdepends=('sonarr' 'radarr' 'plex-media-server' 'emby-server')
+replaces=('plexrequests' 'ombi-beta')
+provides=('ombi')
+conflicts=('ombi')
+options=('staticlibs')
+backup=('opt/Ombi/Ombi.sqlite')
+install='ombi.install'
+noextract=("${pkgname}.tar.gz")
+source=("${pkgname}.tar.gz::https://ci.appveyor.com/api/projects/tidusjar/requestplex/artifacts/linux.tar.gz"
+ 'ombi.service'
+ 'ombi.sysusers')
+sha256sums=('c29353ff9b608a869a286190ba4c7f28fb51623e9998ee62ca715f5cacdae09a'
+ '601f9ba604c6767722397db977a9d73e800127d4a33c5511439e112d22660eba'
+ '480941bb5c96b9e6a155d6feca16f56c74d7f13a49fc94f36132a548bd53dc0a')
+
+pkgver() {
+ curl -s https://ci.appveyor.com/api/projects/tidusjar/requestplex | grep -Pom 1 '"version":"\K[^"]*'
+}
+
+package() {
+ install -dm755 "${pkgdir}/opt/Ombi"
+ tar xzf "${pkgname}.tar.gz" -C "${pkgdir}/opt/Ombi"
+ chmod +x "${pkgdir}/opt/Ombi/Ombi"
+ install -Dm644 "${srcdir}/ombi.service" "${pkgdir}/usr/lib/systemd/system/ombi.service"
+ install -Dm644 "${srcdir}/ombi.sysusers" "${pkgdir}/usr/lib/sysusers.d/ombi.conf"
+}
diff --git a/ombi.install b/ombi.install
new file mode 100644
index 000000000000..b6f77d09d0a9
--- /dev/null
+++ b/ombi.install
@@ -0,0 +1,14 @@
+post_install() {
+ systemd-sysusers ombi.conf
+ chown -R ombi:ombi /opt/Ombi
+}
+
+post_upgrade() {
+ chown -R ombi:ombi /opt/Ombi
+ systemctl daemon-reload
+}
+
+post_remove() {
+ systemctl stop ombi.service
+ true
+}
diff --git a/ombi.service b/ombi.service
new file mode 100644
index 000000000000..c7f7419e19eb
--- /dev/null
+++ b/ombi.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Ombi
+After=network.target
+
+[Service]
+User=ombi
+Group=ombi
+WorkingDirectory=/opt/Ombi
+Type=simple
+ExecStart=/opt/Ombi/Ombi
+TimeoutStopSec=30
+Restart=on-failure
+RestartSec=5
+
+[Install]
+WantedBy=multi-user.target
diff --git a/ombi.sysusers b/ombi.sysusers
new file mode 100644
index 000000000000..189fa39e052f
--- /dev/null
+++ b/ombi.sysusers
@@ -0,0 +1 @@
+u ombi - "ombi" /opt/Ombi