summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--020-onevpl-cpu-disable-gtest-werror.patch18
-rw-r--r--PKGBUILD11
3 files changed, 5 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d8cd4b84ea3..52ab4b9967dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onevpl-cpu-git
pkgdesc = oneVPL runtime implementation for CPU (git version)
- pkgver = 2023.1.0.r0.g2c8c32a
+ pkgver = 2023.1.2.r0.g748f32e
pkgrel = 1
url = https://www.intel.com/content/www/us/en/developer/tools/oneapi/onevpl.html
arch = x86_64
@@ -19,9 +19,7 @@ pkgbase = onevpl-cpu-git
conflicts = onevpl-cpu
source = git+https://github.com/oneapi-src/oneVPL-cpu.git
source = 010-onevpl-cpu-fix-build.patch
- source = 020-onevpl-cpu-disable-gtest-werror.patch
sha256sums = SKIP
sha256sums = ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb
- sha256sums = a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980
pkgname = onevpl-cpu-git
diff --git a/020-onevpl-cpu-disable-gtest-werror.patch b/020-onevpl-cpu-disable-gtest-werror.patch
deleted file mode 100644
index ec27df214972..000000000000
--- a/020-onevpl-cpu-disable-gtest-werror.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/test/unit/googletest/googletest/cmake/internal_utils.cmake
-+++ b/test/unit/googletest/googletest/cmake/internal_utils.cmake
-@@ -82,13 +82,13 @@ macro(config_compiler_and_linker)
- # http://stackoverflow.com/questions/3232669 explains the issue.
- set(cxx_base_flags "${cxx_base_flags} -wd4702")
- elseif (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
-- set(cxx_base_flags "-Wall -Wshadow -Werror -Wconversion")
-+ set(cxx_base_flags "-Wall -Wshadow -Wconversion")
- set(cxx_exception_flags "-fexceptions")
- set(cxx_no_exception_flags "-fno-exceptions")
- set(cxx_strict_flags "-W -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wredundant-decls")
- set(cxx_no_rtti_flags "-fno-rtti")
- elseif (CMAKE_COMPILER_IS_GNUCXX)
-- set(cxx_base_flags "-Wall -Wshadow -Werror")
-+ set(cxx_base_flags "-Wall -Wshadow")
- if(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 7.0.0)
- set(cxx_base_flags "${cxx_base_flags} -Wno-error=dangling-else")
- endif()
diff --git a/PKGBUILD b/PKGBUILD
index 08f5853c9308..027930f283ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=onevpl-cpu-git
-pkgver=2023.1.0.r0.g2c8c32a
+pkgver=2023.1.2.r0.g748f32e
pkgrel=1
pkgdesc='oneVPL runtime implementation for CPU (git version)'
arch=('x86_64')
@@ -12,15 +12,12 @@ makedepends=('git' 'cmake' 'meson' 'nasm' 'onevpl' 'python' 'xxhash' 'yasm')
provides=('onevpl-cpu' 'onevpl-runtime')
conflicts=('onevpl-cpu')
source=('git+https://github.com/oneapi-src/oneVPL-cpu.git'
- '010-onevpl-cpu-fix-build.patch'
- '020-onevpl-cpu-disable-gtest-werror.patch')
+ '010-onevpl-cpu-fix-build.patch')
sha256sums=('SKIP'
- 'ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb'
- 'a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980')
+ 'ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb')
prepare() {
patch -d oneVPL-cpu -Np1 -i "${srcdir}/010-onevpl-cpu-fix-build.patch"
- patch -d oneVPL-cpu -Np1 -i "${srcdir}/020-onevpl-cpu-disable-gtest-werror.patch"
}
pkgver() {
@@ -59,5 +56,5 @@ check() {
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}