summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 718126e8bb87..22b5560823a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Laurent Treguier <laurent@treguier.org>
-_oomox_ver=1.6.2.1
+_oomox_ver=1.7.0.1
_numix_ver=1.9.0
_materia_ver=20180311
_materia_cmt=df30959eb068ef55db18a18ed23a4a1c79129768
+_arc_cmt=c49e1f7fb0aa937789f7c2430c74479e66b6b230
_archdroid_ver=1.0.2
_gnome_colors_ver=5.5.3
_oomoxify_ver=1.0
@@ -11,10 +12,10 @@ _oomoxify_ver=1.0
pkgname=oomox
pkgver=${_oomox_ver}
pkgrel=1
-pkgdesc='Graphical application for generating different color variations of Numix/Materia theme (GTK2, GTK3), gnome-colors and ArchDroid icon themes.
+pkgdesc='Graphical application for generating different color variations of Numix/Materia/Arc theme (GTK2, GTK3), gnome-colors and ArchDroid icon themes.
Have a hack for HiDPI in gtk2.'
arch=('i686' 'x86_64')
-url='https://github.com/actionless/oomox'
+url='https://github.com/themix-project/oomox'
license=('GPL3')
depends=(
'coreutils'
@@ -51,14 +52,16 @@ conflicts=('oomox-git')
source=(
"oomox-${_oomox_ver}.tar.gz::https://github.com/themix-project/oomox/archive/${_oomox_ver}.tar.gz"
"oomox-gtk-theme-${_numix_ver}.tar.gz::https://github.com/themix-project/oomox-gtk-theme/archive/${_numix_ver}.tar.gz"
- "materia-theme-${_materia_cmt}.zip::https://github.com/actionless/materia-theme/archive/${_materia_cmt}.zip"
+ "materia-theme-${_materia_cmt}.tar.gz::https://github.com/actionless/materia-theme/archive/${_materia_cmt}.tar.gz"
+ "arc-theme-${_arc_cmt}.tar.gz::https://github.com/actionless/arc-theme/archive/${_arc_cmt}.tar.gz"
"archdroid-icon-theme-${_archdroid_ver}.tar.gz::https://github.com/themix-project/oomox-archdroid-icon-theme/archive/${_archdroid_ver}.tar.gz"
"gnome-colors-icon-theme-${_gnome_colors_ver}.tar.gz::https://github.com/themix-project/oomox-gnome-colors-icon-theme/archive/${_gnome_colors_ver}.tar.gz"
"oomoxify-${_oomoxify_ver}.tar.gz::https://github.com/themix-project/oomoxify/archive/${_oomoxify_ver}.tar.gz"
)
-md5sums=('ddc61813a332e068e619cd7cf90d26f2'
+md5sums=('cac9a25ed295cfaadb81be0f7c174ea6'
'0769a6c072d8ad7661a16b67a6bcdd48'
- '7da360ebc9303ef388a6ad9dc8e06222'
+ '47bb49b8560bea49726b02d6af1fee6a'
+ '23460fc1c478f6595a56c9a6a98bdac8'
'cb669130685dcbf03a8f7f5738c71dc6'
'ae3250f1dce9505dbaa60d92dcb9a239'
'df970e658de7668a7088bd445e4634fb')
@@ -67,15 +70,18 @@ prepare() {
cd ${srcdir}
cp -pr "${pkgname}-gtk-theme-${_numix_ver}"/* "${pkgname}-${_oomox_ver}/plugins/theme_oomox/gtk-theme"
cp -pr "materia-theme-${_materia_cmt}"/* "${pkgname}-${_oomox_ver}/plugins/theme_materia/materia-theme"
+ cp -pr "arc-theme-${_arc_cmt}"/* "${pkgname}-${_oomox_ver}/plugins/theme_arc/arc-theme"
cp -pr "archdroid-icon-theme-${_archdroid_ver}"/* "${pkgname}-${_oomox_ver}/plugins/icons_archdroid/archdroid-icon-theme"
cp -pr "gnome-colors-icon-theme-${_gnome_colors_ver}"/* "${pkgname}-${_oomox_ver}/plugins/icons_gnomecolors/gnome-colors-icon-theme"
cp -pr "oomoxify-${_oomoxify_ver}"/* "${pkgname}-${_oomox_ver}/plugins/oomoxify"
}
package() {
+ _oomox_dir="/opt/${pkgname}"
+ _oomox_gui_dir="${_oomox_dir}/oomox_gui"
install -d "${pkgdir}/opt/${pkgname}"
cd "${srcdir}/${pkgname}-${_oomox_ver}"
sed -i 's/rm -r/rm -rf/g' packaging/install.sh
- ./packaging/install.sh . "${pkgdir}"
- python -O -m compileall "${pkgdir}/opt/${pkgname}/oomox_gui"
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install
+ python -O -m compileall "${pkgdir}/${_oomox_gui_dir}" -d "${_oomox_gui_dir}"
}