summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE42
-rw-r--r--PKGBUILD31
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01675896d29a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = open-axiom
+ pkgdesc = open source platform for symbolic, algebraic, and numerical computations
+ pkgver = 1.4.2
+ pkgrel = 5
+ url = http://www.open-axiom.org
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = sbcl
+ makedepends = texlive-core
+ depends = qt4
+ depends = libxpm
+ options = !strip
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/project/open-axiom/1.4.2/open-axiom-1.4.2.tar.bz2
+ source = LICENSE
+ md5sums = 521850b13eaefdf4662823da16c97897
+ md5sums = eec8e6188dcdf22d27683c197cea75e8
+
+pkgname = open-axiom
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6953f98e8c66
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,42 @@
+License
+
+OpenAxiom is an open source software distributed under terms of the Modified BSD license.
+
+Copyrights remain with the original copyright holders. Use of this material is by permission and/or license. Individual files contain reference to these applicable copyrights. The copyright and license statements are collected here for reference.
+Portions Copyright (C) 2007-2011, Gabriel Dos Reis
+
+All modifications applied to the build-improvements branch of Axiom, and to the OpenAxiom project are covered by this copyright and the BSD-type License reproduced below.
+Portions Copyright (C) 2003-2007, The Axiom Team
+
+The Axiom Team is the collective name for the people who have contributed to the Axiom project. Where no other copyright statement is noted in a file this copyright will apply.
+Portions Copyright (C) 1991-2002, The Numerical Algorithms Group Ltd. All rights reserved.
+
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are
+ met:
+
+ - Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ - Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ - Neither the name of The Numerical Algorithms Group Ltd. nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
+ IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+ TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+ PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
+ OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+ EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+ PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+ PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+ LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+ NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b05dfad1337
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: karnath <karnathtorjian@gmail.com>
+# Former Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Sergey Khorev <sergey.khorev@gmail.com>
+pkgname=open-axiom
+pkgver=1.4.2
+pkgrel=5
+pkgdesc="open source platform for symbolic, algebraic, and numerical computations"
+arch=('i686' 'x86_64')
+license=('custom')
+makedepends=('sbcl' 'texlive-core')
+depends=('qt4' 'libxpm')
+options=('!strip' '!emptydirs')
+url="http://www.open-axiom.org"
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2" "LICENSE")
+md5sums=('521850b13eaefdf4662823da16c97897' 'eec8e6188dcdf22d27683c197cea75e8')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i configure -e 's/for ac_prog in moc/for ac_prog in moc-qt4/' \
+ -e 's/for ac_prog in qmake/for ac_prog in qmake-qt4/' \
+ -e "s/lt_prog_compiler_static='-static'/lt_prog_compiler_static=''/" \
+ -e "s/lt_prog_compiler_static_CXX='-static'/lt_prog_compiler_static_CXX=''/"
+ ./configure --prefix=/usr --with-lisp=sbcl
+ make -j1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR=$pkgdir install
+ install -D -m644 "$srcdir/LICENSE" $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}