summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e3d7748c44d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Feb 26 23:57:37 UTC 2017
+pkgbase = open-jtalk
+ pkgdesc = Open JTalk is a Japanese text-to-speech synthesis system. This software is released under the Modified BSD license.
+ pkgver = 1.10
+ pkgrel = 1
+ url = https://sourceforge.net/projects/open-jtalk/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = hts-engine
+ depends = gcc-libs-multilib
+ source = https://downloads.sourceforge.net/project/open-jtalk/Open%20JTalk/open_jtalk-1.10/open_jtalk-1.10.tar.gz
+ md5sums = 2279e87a9e6076d9eeae08c2e70173ef
+
+pkgname = open-jtalk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b3430ac30e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ken Swenson <flat@imo.uto.moe>
+pkgname=open-jtalk
+pkgver=1.10
+pkgrel=1
+pkgdesc="Open JTalk is a Japanese text-to-speech synthesis system. This software is released under the Modified BSD license."
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/open-jtalk/"
+license=('BSD')
+depends=('gcc-libs-multilib')
+makedepends=('hts-engine')
+source=("https://downloads.sourceforge.net/project/open-jtalk/Open%20JTalk/open_jtalk-$pkgver/open_jtalk-$pkgver.tar.gz")
+md5sums=('2279e87a9e6076d9eeae08c2e70173ef')
+
+build() {
+ cd "open_jtalk-$pkgver"
+ ./configure --prefix=/usr --with-hts-engine-header-path=/usr/include --with-hts-engine-library-path=/usr/lib
+ make
+}
+
+package() {
+ cd "open_jtalk-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ mv "${pkgdir}/usr/dic" "${pkgdir}/usr/share/${pkgname}/dic"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}