summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD25
-rw-r--r--open-numismat-bin.install27
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b31cf5dfb99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = open-numismat-bin
+ pkgdesc = Coin collecting software to organize and manage your own coin catalogue.
+ pkgver = 1.8.7
+ pkgrel = 1
+ url = http://opennumismat.github.io
+ install = open-numismat-bin.install
+ arch = any
+ groups =
+ license = GPL3
+ depends = bash-completion
+ depends = hicolor-icon-theme
+ depends = pyside2
+ depends = python
+ depends = python-dateutil
+ depends = python-jinja
+ depends = python-django
+ depends = python-lxml
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = python-xlrd
+ depends = qt5-base
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/OpenNumismat/open-numismat/releases/download/1.8.7/open-numismat_1.8.7_all.deb
+ sha512sums = d0d8bc0120b00418adbd6737c31ef59e02435b9430d8ca3b805caf19c73c6628be7d1a326b0a80f2a55795a9f2587c1eebce63c69c5c25636a1f0e5541b167a4
+
+pkgname = open-numismat-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fe154b22981
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tyler <tyler@cyb3r.space>
+
+pkgname=open-numismat-bin
+pkgver=1.8.7
+pkgrel=1
+pkgdesc='Coin collecting software to organize and manage your own coin catalogue.'
+arch=('any')
+url="http://opennumismat.github.io"
+license=('GPL3')
+groups=('')
+depends=('bash-completion' 'hicolor-icon-theme' 'pyside2' 'python' 'python-dateutil' 'python-jinja' 'python-django' 'python-lxml' 'python-matplotlib' 'python-numpy' 'python-xlrd' 'qt5-base')
+options=('!strip' '!emptydirs')
+install=open-numismat-bin.install
+source=("https://github.com/OpenNumismat/open-numismat/releases/download/${pkgver}/open-numismat_${pkgver}_all.deb")
+sha512sums=('d0d8bc0120b00418adbd6737c31ef59e02435b9430d8ca3b805caf19c73c6628be7d1a326b0a80f2a55795a9f2587c1eebce63c69c5c25636a1f0e5541b167a4')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+ # python3 directory needs to point to correct python-current version, wierd debian python packaging formats
+ LATEST_PYTHON=$(ls -l /usr/bin/python3 | cut -d ">" -f 2 | tr -d '[:space:]')
+ mv "${pkgdir}/usr/lib/python3/" "${pkgdir}/usr/lib/$LATEST_PYTHON/"
+ mv "${pkgdir}/usr/lib/$LATEST_PYTHON/dist-packages" "${pkgdir}/usr/lib/$LATEST_PYTHON/site-packages"
+}
diff --git a/open-numismat-bin.install b/open-numismat-bin.install
new file mode 100644
index 000000000000..5b43458178f8
--- /dev/null
+++ b/open-numismat-bin.install
@@ -0,0 +1,27 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+
+ if which py3compile >/dev/null 2>&1; then
+ py3compile -p open-numismat
+ fi
+
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+
+ if which py3clean >/dev/null 2>&1; then
+ py3clean -p open-numismat
+ else
+ echo "Already cleaned"
+ fi
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}