summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-documents-ui-common.install14
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94aceda51aff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jan 2 21:54:58 UTC 2016
+pkgbase = open-xchange-documents-ui-common
+ pkgdesc = Open-Xchange
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-documents-ui-common.install
+ arch = any
+ groups = open-xchange
+ license = GPLv2
+ depends = open-xchange-appsuite-manifest
+ provides = open-xchange-documents-ui-common
+ source = https://software.open-xchange.com/products/appsuite/stable/office-web/DebianJessie/all/open-xchange-documents-ui-common_7.8.0-6_all.deb
+ sha256sums = 3193a9ab84898097a0d5094daba358981894af5b2c235e4971ea53c5c3a8620d
+
+pkgname = open-xchange-documents-ui-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a819c06c1783
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-documents-ui-common
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='Open-Xchange'
+groups=('open-xchange')
+install='open-xchange-documents-ui-common.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=('open-xchange-appsuite-manifest')
+makedepends=()
+conflicts=()
+provides=('open-xchange-documents-ui-common')
+source=('https://software.open-xchange.com/products/appsuite/stable/office-web/DebianJessie/all/open-xchange-documents-ui-common_7.8.0-6_all.deb')
+sha256sums=('3193a9ab84898097a0d5094daba358981894af5b2c235e4971ea53c5c3a8620d')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-documents-ui-common.install b/open-xchange-documents-ui-common.install
new file mode 100644
index 000000000000..27ab8bbd33a0
--- /dev/null
+++ b/open-xchange-documents-ui-common.install
@@ -0,0 +1,14 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if ! id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}