summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gzbin0 -> 11723 bytes
-rw-r--r--0002-Pending-changes-for-openafs-stable-1_8_x.patch.gzbin0 -> 166632 bytes
-rw-r--r--0003-Linux-Introduce-file-mapping-readpage-helpers.patch103
-rw-r--r--0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch132
-rw-r--r--0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch121
-rw-r--r--0006-Adjust-RedHat-config-and-service-files.patch (renamed from 0001-Adjust-RedHat-config-and-service-files.patch)8
-rw-r--r--PKGBUILD31
8 files changed, 398 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e42b1f27dd5c..b578434912ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openafs
pkgdesc = Open source implementation of the AFS distributed file system
pkgver = 1.8.8.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.openafs.org
install = openafs.install
arch = i686
@@ -21,10 +21,20 @@ pkgbase = openafs
source = http://openafs.org/dl/openafs/1.8.8.1/openafs-1.8.8.1-src.tar.bz2
source = http://openafs.org/dl/openafs/1.8.8.1/openafs-1.8.8.1-doc.tar.bz2
source = tmpfiles.d-openafs.conf
- source = 0001-Adjust-RedHat-config-and-service-files.patch
+ source = 0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gz
+ source = 0002-Pending-changes-for-openafs-stable-1_8_x.patch.gz
+ source = 0003-Linux-Introduce-file-mapping-readpage-helpers.patch
+ source = 0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch
+ source = 0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch
+ source = 0006-Adjust-RedHat-config-and-service-files.patch
sha256sums = e7c4bed7075bcd6402e3f0c2d5b9dbe76ad2ee3c5fd5ddc3973a3356ca23ef44
sha256sums = cb5ecedc2e164bea3b48c6b2c9d6f1c36bfde91d068a4c62a9c885df48fe8e6b
sha256sums = 18d7b0173bbffbdc212f4e58c5b3ce369adf868452aabc3485f2a6a2ddb35d68
- sha256sums = e93cb374badf24662ebead212525e386cdc05e32c7606ec7b4c0da2e3f103ae5
+ sha256sums = 8e9fd9e37fe55a379534f4ccb48be9f37c141e13e7f28aa834793eaa7ade1bd4
+ sha256sums = eb78d128fa3bfad82e40c9077ff972f0dd34a9745a6463ae2ac0f6cb9d912853
+ sha256sums = 0e902a093d5bad45f422ef1fc47c686503315fa3049f304eadb8b9dae6be8027
+ sha256sums = 0bb7ac77fa5d3d42bd78f67974ecbcc7cb8973e2859d74c361cb5fa18275cb8e
+ sha256sums = 7c7c6d9e76b436f95ba46138b979694cb50ff33eba2de82f1f5d426213f1768c
+ sha256sums = d5b8223ab81a84639bd5614dffe67724640f2ea437374d2b0f2d066bd53cde2d
pkgname = openafs
diff --git a/0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gz b/0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gz
new file mode 100644
index 000000000000..1f71fa277b33
--- /dev/null
+++ b/0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gz
Binary files differ
diff --git a/0002-Pending-changes-for-openafs-stable-1_8_x.patch.gz b/0002-Pending-changes-for-openafs-stable-1_8_x.patch.gz
new file mode 100644
index 000000000000..d485a2ea7315
--- /dev/null
+++ b/0002-Pending-changes-for-openafs-stable-1_8_x.patch.gz
Binary files differ
diff --git a/0003-Linux-Introduce-file-mapping-readpage-helpers.patch b/0003-Linux-Introduce-file-mapping-readpage-helpers.patch
new file mode 100644
index 000000000000..da1f03cbb0de
--- /dev/null
+++ b/0003-Linux-Introduce-file-mapping-readpage-helpers.patch
@@ -0,0 +1,103 @@
+From 97054ed3d994f8d6218bf8db05c41ead218200e3 Mon Sep 17 00:00:00 2001
+From: Cheyenne Wills <cwills@sinenomine.net>
+Date: Tue, 5 Jul 2022 10:28:10 -0600
+Subject: [PATCH 3/6] Linux: Introduce file mapping readpage helpers
+
+Create a helper function that determines if a file's
+ i_mapping->a_ops->readpage
+is NULL.
+
+Create a helper function that calls a file's
+ i_mapping->a_ops->readpage
+
+There are no functional changes with this commit.
+
+Note: This commit isolates references to 'readpage' so that future
+commits can change the name in a more straight forward manner.
+
+Change-Id: If3ad33766c7a3bce27c2aa3c3b409157264230b1
+Reviewed-on: https://gerrit.openafs.org/15039
+Tested-by: BuildBot <buildbot@rampaginggeek.com>
+Reviewed-by: Andrew Deason <adeason@sinenomine.net>
+Reviewed-by: Benjamin Kaduk <kaduk@mit.edu>
+(cherry picked from commit a81f7300f08d6e515adbde4bce4b72a3102b60f9)
+---
+ src/afs/LINUX/osi_vnodeops.c | 34 +++++++++++++++++++++++++++++-----
+ 1 file changed, 29 insertions(+), 5 deletions(-)
+
+diff --git a/src/afs/LINUX/osi_vnodeops.c b/src/afs/LINUX/osi_vnodeops.c
+index 54118637f..b834a405c 100644
+--- a/src/afs/LINUX/osi_vnodeops.c
++++ b/src/afs/LINUX/osi_vnodeops.c
+@@ -2206,6 +2206,18 @@ afs_linux_put_link(struct dentry *dentry, struct nameidata *nd)
+
+ #endif /* USABLE_KERNEL_PAGE_SYMLINK_CACHE */
+
++/*
++ * Call the mapping function that reads data for a given page.
++ * Note: When we return, it is expected that the page is unlocked. It is the
++ * responsibility of the called function (e.g. ->readpage) to unlock the given
++ * page, even when an error occurs.
++ */
++static int
++mapping_read_page(struct address_space *mapping, struct page *page)
++{
++ return mapping->a_ops->readpage(NULL, page);
++}
++
+ /* Populate a page by filling it from the cache file pointed at by cachefp
+ * (which contains indicated chunk)
+ * If task is NULL, the page copy occurs syncronously, and the routine
+@@ -2272,9 +2284,9 @@ afs_linux_read_cache(struct file *cachefp, struct page *page,
+
+ if (!PageUptodate(cachepage)) {
+ ClearPageError(cachepage);
+- /* Note that ->readpage always handles unlocking the given page, even
+- * when an error is returned. */
+- code = cachemapping->a_ops->readpage(NULL, cachepage);
++ /* Note that mapping_read_page always handles unlocking the given page,
++ * even when an error is returned. */
++ code = mapping_read_page(cachemapping, cachepage);
+ if (!code && !task) {
+ wait_on_page_locked(cachepage);
+ }
+@@ -2308,6 +2320,17 @@ afs_linux_read_cache(struct file *cachefp, struct page *page,
+ return code;
+ }
+
++/*
++ * Return true if the file has a mapping that can read pages
++ */
++static int inline
++file_can_read_pages(struct file *fp)
++{
++ if (fp->f_dentry->d_inode->i_mapping->a_ops->readpage != NULL)
++ return 1;
++ return 0;
++}
++
+ static int inline
+ afs_linux_readpage_fastpath(struct file *fp, struct page *pp, int *codep)
+ {
+@@ -2403,7 +2426,8 @@ afs_linux_readpage_fastpath(struct file *fp, struct page *pp, int *codep)
+ AFS_GLOCK();
+ goto out;
+ }
+- if (!cacheFp->f_dentry->d_inode->i_mapping->a_ops->readpage) {
++
++ if (!file_can_read_pages(cacheFp)) {
+ cachefs_noreadpage = 1;
+ AFS_GLOCK();
+ goto out;
+@@ -2871,7 +2895,7 @@ get_dcache_readahead(struct dcache **adc, struct file **acacheFp,
+ code = -1;
+ goto out;
+ }
+- if (cacheFp->f_dentry->d_inode->i_mapping->a_ops->readpage == NULL) {
++ if (!file_can_read_pages(cacheFp)) {
+ cachefs_noreadpage = 1;
+ /* No mapping function */
+ code = -1;
+--
+2.37.1
+
diff --git a/0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch b/0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch
new file mode 100644
index 000000000000..1e473316ab3d
--- /dev/null
+++ b/0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch
@@ -0,0 +1,132 @@
+From f7d5510aa486caeb69c688099bfba77609d82ed5 Mon Sep 17 00:00:00 2001
+From: Cheyenne Wills <cwills@sinenomine.net>
+Date: Tue, 5 Jul 2022 11:45:29 -0600
+Subject: [PATCH 4/6] Linux-5.19: Rename aops readpage to read_folio
+
+With Linux commits:
+ mm,fs: Remove aops->readpage (7e0a126519)
+ fs: Introduce aops->read_folio (5efe7448a1)
+
+the address space operations method 'readpage' was replaced with
+read_folio. The operation behaves the same, except instead of taking a
+struct page parameter, the new function takes a folio structure.
+
+Add an autoconf test for the address space operation entry read_folio
+
+Replace the references to an address space operations' readpage with
+read_folio. Note that the function Linux page_folio can be used to
+obtain the required pointer to the folio for a given page.
+
+Introduce afs_linux_read_folio that accepts a folio and calls
+afs_linux_readpage with the page associated with that folio.
+
+Change-Id: I2c43a9bfb26042f7cc2c55807d46b33769f2594a
+Reviewed-on: https://gerrit.openafs.org/15040
+Reviewed-by: Andrew Deason <adeason@sinenomine.net>
+Reviewed-by: Benjamin Kaduk <kaduk@mit.edu>
+Reviewed-by: Michael Meffie <mmeffie@sinenomine.net>
+Tested-by: BuildBot <buildbot@rampaginggeek.com>
+(cherry picked from commit bfb852197edcbe0c38c499faecd7c1be23308a20)
+---
+ src/afs/LINUX/osi_vnodeops.c | 36 +++++++++++++++++++++++++++++++++++
+ src/cf/linux-kernel-struct.m4 | 2 ++
+ 2 files changed, 38 insertions(+)
+
+diff --git a/src/afs/LINUX/osi_vnodeops.c b/src/afs/LINUX/osi_vnodeops.c
+index b834a405c..04f13a1b1 100644
+--- a/src/afs/LINUX/osi_vnodeops.c
++++ b/src/afs/LINUX/osi_vnodeops.c
+@@ -2215,7 +2215,11 @@ afs_linux_put_link(struct dentry *dentry, struct nameidata *nd)
+ static int
+ mapping_read_page(struct address_space *mapping, struct page *page)
+ {
++#if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_READ_FOLIO)
++ return mapping->a_ops->read_folio(NULL, page_folio(page));
++#else
+ return mapping->a_ops->readpage(NULL, page);
++#endif
+ }
+
+ /* Populate a page by filling it from the cache file pointed at by cachefp
+@@ -2326,8 +2330,13 @@ afs_linux_read_cache(struct file *cachefp, struct page *page,
+ static int inline
+ file_can_read_pages(struct file *fp)
+ {
++#if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_READ_FOLIO)
++ if (fp->f_dentry->d_inode->i_mapping->a_ops->read_folio != NULL)
++ return 1;
++#else
+ if (fp->f_dentry->d_inode->i_mapping->a_ops->readpage != NULL)
+ return 1;
++#endif
+ return 0;
+ }
+
+@@ -2849,6 +2858,16 @@ afs_linux_readpage(struct file *fp, struct page *pp)
+ return code;
+ }
+
++#if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_READ_FOLIO)
++static int
++afs_linux_read_folio(struct file *fp, struct folio *folio)
++{
++ struct page *pp = &folio->page;
++
++ return afs_linux_readpage(fp, pp);
++}
++#endif
++
+ /*
+ * Updates the adc and acacheFp parameters
+ * Returns:
+@@ -3536,7 +3555,11 @@ static struct inode_operations afs_file_iops = {
+ };
+
+ static struct address_space_operations afs_file_aops = {
++#if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_READ_FOLIO)
++ .read_folio = afs_linux_read_folio,
++#else
+ .readpage = afs_linux_readpage,
++#endif
+ #if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_READAHEAD)
+ .readahead = afs_linux_readahead,
+ #else
+@@ -3609,9 +3632,22 @@ afs_symlink_filler(struct file *file, struct page *page)
+ unlock_page(page);
+ return code;
+ }
++#if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_READ_FOLIO)
++static int
++afs_symlink_filler_folio(struct file *file, struct folio *folio)
++{
++ struct page *page = &folio->page;
++ return afs_symlink_filler(file, page);
++}
++#endif
++
+
+ static struct address_space_operations afs_symlink_aops = {
++#if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_READ_FOLIO)
++ .read_folio = afs_symlink_filler_folio
++#else
+ .readpage = afs_symlink_filler
++#endif
+ };
+ #endif /* USABLE_KERNEL_PAGE_SYMLINK_CACHE */
+
+diff --git a/src/cf/linux-kernel-struct.m4 b/src/cf/linux-kernel-struct.m4
+index 597289bc8..3d4b10b13 100644
+--- a/src/cf/linux-kernel-struct.m4
++++ b/src/cf/linux-kernel-struct.m4
+@@ -7,6 +7,8 @@ dnl linux 5.18 replaced set_page_dirty with dirty_folio
+ AC_CHECK_LINUX_STRUCT([address_space_operations], [dirty_folio], [fs.h])
+ dnl linux 5.18 replaced readpages with readahead (introduced in 5.8)
+ AC_CHECK_LINUX_STRUCT([address_space_operations], [readahead], [fs.h])
++dnl linux 5.18 replaced readpage with read_folio
++AC_CHECK_LINUX_STRUCT([address_space_operations], [read_folio], [fs.h])
+ AC_CHECK_LINUX_STRUCT([backing_dev_info], [name],
+ [backing-dev.h])
+ AC_CHECK_LINUX_STRUCT([cred], [session_keyring], [cred.h])
+--
+2.37.1
+
diff --git a/0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch b/0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch
new file mode 100644
index 000000000000..7421a7b8393d
--- /dev/null
+++ b/0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch
@@ -0,0 +1,121 @@
+From bf5c975cc5585a9170d61e83d5de2982e3d0a765 Mon Sep 17 00:00:00 2001
+From: Cheyenne Wills <cwills@sinenomine.net>
+Date: Tue, 5 Jul 2022 10:33:19 -0600
+Subject: [PATCH 5/6] Linux-5.19: Remove flags from aops->write_begin
+
+The Linux 5.19 commits:
+
+ fs: Remove aop flags parameter from grab_cache_page_write_begin()
+ (b7446e7c)
+ fs: Remove flags parameter from aops->write_begin (9d6b0cd7)
+
+removed the flags parameter from the address space operations
+'write_begin' as well as removing the flags parameter from the Linux
+function 'grab_cache_page_write_begin'.
+
+Add an autoconf test to see if grab_cache_page_write_begin takes 2 or
+3 parameters. Use this as a test to determine if the address space
+operations 'write_begin' takes a flags parameter.
+
+Create a version of afs_linux_write_begin that does not take a flags
+parameter, which also calls grab_cache_page_write_begin without flags.
+
+Change-Id: Ib98c615e6964202748c78037c9ecac459fc3372b
+Reviewed-on: https://gerrit.openafs.org/15041
+Tested-by: BuildBot <buildbot@rampaginggeek.com>
+Reviewed-by: Andrew Deason <adeason@sinenomine.net>
+Reviewed-by: Michael Meffie <mmeffie@sinenomine.net>
+Reviewed-by: Benjamin Kaduk <kaduk@mit.edu>
+(cherry picked from commit 52d8df218ff27c139ede221ec4decf593610fc47)
+---
+ src/afs/LINUX/osi_compat.h | 4 +++-
+ src/afs/LINUX/osi_vnodeops.c | 30 +++++++++++++++++++++++++++++-
+ src/cf/linux-kernel-func.m4 | 7 ++++++-
+ 3 files changed, 38 insertions(+), 3 deletions(-)
+
+diff --git a/src/afs/LINUX/osi_compat.h b/src/afs/LINUX/osi_compat.h
+index 53a079b67..9a080da31 100644
+--- a/src/afs/LINUX/osi_compat.h
++++ b/src/afs/LINUX/osi_compat.h
+@@ -138,7 +138,9 @@ hlist_unhashed(const struct hlist_node *h) {
+ #define AOP_WRITEPAGE_ACTIVATE WRITEPAGE_ACTIVATE
+ #endif
+
+-#if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_WRITE_BEGIN) && !defined(HAVE_LINUX_GRAB_CACHE_PAGE_WRITE_BEGIN)
++#if defined(STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_WRITE_BEGIN) && \
++ !defined(HAVE_LINUX_GRAB_CACHE_PAGE_WRITE_BEGIN_WITHFLAGS) && \
++ !defined(HAVE_LINUX_GRAB_CACHE_PAGE_WRITE_BEGIN_NOFLAGS)
+ static inline struct page *
+ grab_cache_page_write_begin(struct address_space *mapping, pgoff_t index,
+ unsigned int flags) {
+diff --git a/src/afs/LINUX/osi_vnodeops.c b/src/afs/LINUX/osi_vnodeops.c
+index 04f13a1b1..881d38e06 100644
+--- a/src/afs/LINUX/osi_vnodeops.c
++++ b/src/afs/LINUX/osi_vnodeops.c
+@@ -3480,6 +3480,33 @@ afs_linux_write_end(struct file *file, struct address_space *mapping,
+ return code;
+ }
+
++# if defined(HAVE_LINUX_GRAB_CACHE_PAGE_WRITE_BEGIN_NOFLAGS)
++static int
++afs_linux_write_begin(struct file *file, struct address_space *mapping,
++ loff_t pos, unsigned len,
++ struct page **pagep, void **fsdata)
++{
++ struct page *page;
++ pgoff_t index = pos >> PAGE_SHIFT;
++ unsigned int from = pos & (PAGE_SIZE - 1);
++ int code;
++
++ page = grab_cache_page_write_begin(mapping, index);
++ if (!page) {
++ return -ENOMEM;
++ }
++
++ *pagep = page;
++
++ code = afs_linux_prepare_write(file, page, from, from + len);
++ if (code) {
++ unlock_page(page);
++ put_page(page);
++ }
++
++ return code;
++}
++# else
+ static int
+ afs_linux_write_begin(struct file *file, struct address_space *mapping,
+ loff_t pos, unsigned len, unsigned flags,
+@@ -3505,7 +3532,8 @@ afs_linux_write_begin(struct file *file, struct address_space *mapping,
+
+ return code;
+ }
+-#endif
++# endif /* HAVE_LINUX_GRAB_CACHE_PAGE_WRITE_BEGIN_NOFLAGS */
++#endif /* STRUCT_ADDRESS_SPACE_OPERATIONS_HAS_WRITE_BEGIN */
+
+ #ifndef STRUCT_DENTRY_OPERATIONS_HAS_D_AUTOMOUNT
+ static void *
+diff --git a/src/cf/linux-kernel-func.m4 b/src/cf/linux-kernel-func.m4
+index cd4afe914..27a1d4141 100644
+--- a/src/cf/linux-kernel-func.m4
++++ b/src/cf/linux-kernel-func.m4
+@@ -59,9 +59,14 @@ AC_CHECK_LINUX_FUNC([find_task_by_pid],
+ AC_CHECK_LINUX_FUNC([generic_file_aio_read],
+ [#include <linux/fs.h>],
+ [generic_file_aio_read(NULL,NULL,0,0);])
+-AC_CHECK_LINUX_FUNC([grab_cache_page_write_begin],
++dnl - linux 5.19 removed the flags parameter, need to test
++dnl - with and without the flags parameter
++AC_CHECK_LINUX_FUNC([grab_cache_page_write_begin_withflags],
+ [#include <linux/pagemap.h>],
+ [grab_cache_page_write_begin(NULL, 0, 0);])
++AC_CHECK_LINUX_FUNC([grab_cache_page_write_begin_noflags],
++ [#include <linux/pagemap.h>],
++ [grab_cache_page_write_begin(NULL, 0);])
+ AC_CHECK_LINUX_FUNC([hlist_unhashed],
+ [#include <linux/list.h>],
+ [hlist_unhashed(0);])
+--
+2.37.1
+
diff --git a/0001-Adjust-RedHat-config-and-service-files.patch b/0006-Adjust-RedHat-config-and-service-files.patch
index ded752e10eec..fe4a72688add 100644
--- a/0001-Adjust-RedHat-config-and-service-files.patch
+++ b/0006-Adjust-RedHat-config-and-service-files.patch
@@ -1,15 +1,13 @@
-From 8750603a23dc71bd3d9c65eee792f81e0293bd80 Mon Sep 17 00:00:00 2001
+From 7c474e545ef6ad609b450c371958d849ba5107b1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Michael=20La=C3=9F?= <lass@mail.uni-paderborn.de>
Date: Thu, 19 Feb 2015 19:34:00 +0100
-Subject: [PATCH] Adjust RedHat config and service files
+Subject: [PATCH 6/6] Adjust RedHat config and service files
Basically we reuse upstream's config for RedHat but we change a few things:
* adjust paths to match ArchLinux packaging
* remove the dynamic creation of CellServDB
* enable network traffic encryption by default
-
-Change-Id: I58edd1c30b0915624a386bbae96879345d7e8b4b
---
src/packaging/RedHat/openafs-cacheinfo | 2 +-
src/packaging/RedHat/openafs-client.service | 15 +++++++--------
@@ -66,5 +64,5 @@ index ac9d3c411..0a4b3bfea 100644
[Install]
--
-2.32.0
+2.37.1
diff --git a/PKGBUILD b/PKGBUILD
index 39d33ab6f4a6..296f27fd5aa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=openafs
pkgver=1.8.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Open source implementation of the AFS distributed file system"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.openafs.org"
@@ -24,11 +24,21 @@ install=openafs.install
source=(http://openafs.org/dl/openafs/${pkgver}/${pkgname}-${pkgver}-src.tar.bz2
http://openafs.org/dl/openafs/${pkgver}/${pkgname}-${pkgver}-doc.tar.bz2
tmpfiles.d-openafs.conf
- 0001-Adjust-RedHat-config-and-service-files.patch)
+ 0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gz
+ 0002-Pending-changes-for-openafs-stable-1_8_x.patch.gz
+ 0003-Linux-Introduce-file-mapping-readpage-helpers.patch
+ 0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch
+ 0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch
+ 0006-Adjust-RedHat-config-and-service-files.patch)
sha256sums=('e7c4bed7075bcd6402e3f0c2d5b9dbe76ad2ee3c5fd5ddc3973a3356ca23ef44'
'cb5ecedc2e164bea3b48c6b2c9d6f1c36bfde91d068a4c62a9c885df48fe8e6b'
'18d7b0173bbffbdc212f4e58c5b3ce369adf868452aabc3485f2a6a2ddb35d68'
- 'e93cb374badf24662ebead212525e386cdc05e32c7606ec7b4c0da2e3f103ae5')
+ '8e9fd9e37fe55a379534f4ccb48be9f37c141e13e7f28aa834793eaa7ade1bd4'
+ 'eb78d128fa3bfad82e40c9077ff972f0dd34a9745a6463ae2ac0f6cb9d912853'
+ '0e902a093d5bad45f422ef1fc47c686503315fa3049f304eadb8b9dae6be8027'
+ '0bb7ac77fa5d3d42bd78f67974ecbcc7cb8973e2859d74c361cb5fa18275cb8e'
+ '7c7c6d9e76b436f95ba46138b979694cb50ff33eba2de82f1f5d426213f1768c'
+ 'd5b8223ab81a84639bd5614dffe67724640f2ea437374d2b0f2d066bd53cde2d')
# If you need the kauth tools set this to 1. But be aware that these tools
# are considered insecure since 2003! This also affects the PAM libs.
@@ -37,11 +47,22 @@ ENABLE_KAUTH=0
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ # Changes that have been accepted for OpenAFS 1.8.x
+ zcat "${srcdir}"/0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gz | patch -p1
+
+ # Changes likely to be accepted for OpenAFS 1.8.x
+ zcat "${srcdir}"/0002-Pending-changes-for-openafs-stable-1_8_x.patch.gz | patch -p1
+
+ # Changes to support Linux 5.19
+ patch -p1 < "${srcdir}"/0003-Linux-Introduce-file-mapping-readpage-helpers.patch
+ patch -p1 < "${srcdir}"/0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch
+ patch -p1 < "${srcdir}"/0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch
+
# Adjust RedHat config and service files to our needs
- patch -p1 < "${srcdir}"/0001-Adjust-RedHat-config-and-service-files.patch
+ patch -p1 < "${srcdir}"/0006-Adjust-RedHat-config-and-service-files.patch
# Only needed when changes to configure were made
- # ./regen.sh -q
+ ./regen.sh -q
}
build() {