summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--0bf7d134dc13540b277c10fbd1efb8013aae603e.patch22
-rw-r--r--PKGBUILD66
-rw-r--r--ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch22
4 files changed, 33 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fec4793e42aa..ceefaa0cf023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openbazaar
pkgdesc = Front-end Electron application for talking with the OpenBazaar daemon
- pkgver = 2.2.5
- pkgrel = 2
+ pkgver = 2.3.0
+ pkgrel = 1
url = https://github.com/OpenBazaar/openbazaar-desktop
install = openbazaar.install
arch = i686
@@ -10,16 +10,12 @@ pkgbase = openbazaar
makedepends = npm
depends = electron2
options = !strip
- source = https://github.com/OpenBazaar/openbazaar-desktop/archive/v2.2.5.tar.gz
+ source = https://github.com/OpenBazaar/openbazaar-desktop/archive/v2.3.0.tar.gz
source = openbazaar.js
source = openbazaar.desktop
- source = ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
- source = 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
- md5sums = 572a60b5a7b89e87b039e4bea67db990
+ md5sums = 62d03372b781c1e9316d86836bd7a5d0
md5sums = a6f53663934868281cc8aa88c894ed3c
md5sums = 2e7c7804b970baa7f9274dae47618a52
- md5sums = cc30e1a4742c4e671275842e8b450916
- md5sums = 72266e0d0f3e3137cbea70f0dade7bfc
pkgname = openbazaar
diff --git a/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch b/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
deleted file mode 100644
index ed980625b824..000000000000
--- a/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 0bf7d134dc13540b277c10fbd1efb8013aae603e Mon Sep 17 00:00:00 2001
-From: Gianluca Boiano <morf3089@gmail.com>
-Date: Thu, 20 Sep 2018 14:37:02 +0200
-Subject: [PATCH] uploadToServer replaces deprecated autoSubmit
-
----
- main.js | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/main.js b/main.js
-index ddc4d807b..e968920e2 100644
---- a/main.js
-+++ b/main.js
-@@ -142,7 +142,7 @@ crashReporter.start({
- productName: 'OpenBazaar 2',
- companyName: 'OpenBazaar',
- submitURL: 'http://104.131.17.128:1127/post',
-- autoSubmit: true,
-+ uploadToServer: true,
- extra: {
- bundled: isBundledApp,
- },
diff --git a/PKGBUILD b/PKGBUILD
index 59913f142025..e9e033a0cf6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: robertfoster
pkgname=openbazaar
-pkgver=2.2.5
-pkgrel=2
+pkgver=2.3.0
+pkgrel=1
pkgdesc="Front-end Electron application for talking with the OpenBazaar daemon"
arch=(i686 x86_64)
url="https://github.com/OpenBazaar/openbazaar-desktop"
@@ -10,49 +10,41 @@ license=('MIT')
depends=('electron2')
makedepends=('npm')
source=("https://github.com/OpenBazaar/openbazaar-desktop/archive/v$pkgver.tar.gz"
- "$pkgname.js"
- "$pkgname.desktop"
- ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
- 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
+ "$pkgname.js"
+ "$pkgname.desktop"
)
install=$pkgname.install
options=('!strip')
build(){
- cd $srcdir/$pkgname-desktop-$pkgver
+ cd $srcdir/$pkgname-desktop-$pkgver
- # Some electron fixes
- patch -Np1 -i ../ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
- patch -Np1 -i ../0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
-
- npm install --silent
- npm run build
- npm prune --production
+ npm install --silent
+ npm run build
+ npm prune --production
}
package(){
- cd $srcdir
- appdir="usr/lib/$pkgname"
-
- install -d $pkgdir/${appdir%%/$pkgname}
- cp -rf $pkgname-desktop-$pkgver $pkgdir/$appdir
- install -Dm755 $pkgname.js $pkgdir/usr/bin/$pkgname
- install -Dm644 $pkgname-desktop-$pkgver/imgs/icon.png $pkgdir/usr/share/pixmaps/${pkgname}2.png
- install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
-
- cd $pkgdir/$appdir
- rm -rf .git*
- rm -rf .travis
- cp -rf prod/* js/
- find "${pkgdir}"/${appdir} \
- -name "bin" -prune -exec rm -r '{}' \; \
- -or -name "example" -prune -exec rm -r '{}' \; \
- -or -name "examples" -prune -exec rm -r '{}' \; \
- -or -name "test" -prune -exec rm -r '{}' \;
+ cd $srcdir
+ appdir="usr/lib/$pkgname"
+
+ install -d $pkgdir/${appdir%%/$pkgname}
+ cp -rf $pkgname-desktop-$pkgver $pkgdir/$appdir
+ install -Dm755 $pkgname.js $pkgdir/usr/bin/$pkgname
+ install -Dm644 $pkgname-desktop-$pkgver/imgs/icon.png $pkgdir/usr/share/pixmaps/${pkgname}2.png
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ cd $pkgdir/$appdir
+ rm -rf .git*
+ rm -rf .travis
+ cp -rf prod/* js/
+ find "${pkgdir}"/${appdir} \
+ -name "bin" -prune -exec rm -r '{}' \; \
+ -or -name "example" -prune -exec rm -r '{}' \; \
+ -or -name "examples" -prune -exec rm -r '{}' \; \
+ -or -name "test" -prune -exec rm -r '{}' \;
}
-md5sums=('572a60b5a7b89e87b039e4bea67db990'
- 'a6f53663934868281cc8aa88c894ed3c'
- '2e7c7804b970baa7f9274dae47618a52'
- 'cc30e1a4742c4e671275842e8b450916'
-'72266e0d0f3e3137cbea70f0dade7bfc')
+md5sums=('62d03372b781c1e9316d86836bd7a5d0'
+ 'a6f53663934868281cc8aa88c894ed3c'
+'2e7c7804b970baa7f9274dae47618a52')
diff --git a/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch b/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
deleted file mode 100644
index 1e6df06d3d2f..000000000000
--- a/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From ef26cd0e8014e09b3671500f92c8f1b0d0ebe340 Mon Sep 17 00:00:00 2001
-From: Gianluca Boiano <morf3089@gmail.com>
-Date: Thu, 20 Sep 2018 14:24:39 +0200
-Subject: [PATCH] menu.popup options object should be optional (fix #1560)
-
----
- main.js | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/main.js b/main.js
-index 6d222a7da..ddc4d807b 100644
---- a/main.js
-+++ b/main.js
-@@ -389,7 +389,7 @@ function createWindow() {
- Menu.setApplicationMenu(menu);
-
- ipcMain.on('contextmenu-click', () => {
-- menu.popup();
-+ menu.popup({});
- });
-
- // put logic here to set tray icon based on OS