summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--openbgpd.changelog89
3 files changed, 103 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40f29ad572c3..cbd6b53bd1f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = openbgpd
pkgdesc = A FREE implementation of the Border Gateway Protocol, Version 4
- pkgver = 7.5
- pkgrel = 3
+ pkgver = 8.4
+ pkgrel = 1
url = https://www.openbgpd.org
+ changelog = openbgpd.changelog
arch = x86_64
license = ISC
depends = libevent
- source = https://cdn.openbsd.org/pub/OpenBSD/OpenBGPD/openbgpd-7.5.tar.gz
- source = https://cdn.openbsd.org/pub/OpenBSD/OpenBGPD/openbgpd-7.5.tar.gz.asc
+ depends = libmnl
+ source = https://cdn.openbsd.org/pub/OpenBSD/OpenBGPD/openbgpd-8.4.tar.gz
+ source = https://cdn.openbsd.org/pub/OpenBSD/OpenBGPD/openbgpd-8.4.tar.gz.asc
source = bgpd.service
source = sysusers.conf
validpgpkeys = BA3DA14FEE657A6D7931C08EC755429BA6A969A8
- sha256sums = 67a81b3005cb23416b1c4842f1a1ed63a113c26ef1e91ce9ec0b90dcd5caffea
+ sha256sums = 59c107243d4b5133d7be4d75906af57690882bed58134bc066b7b304993848ed
sha256sums = SKIP
sha256sums = 374fbf93489ba8e5d8722c534e5c899a6c01601d5540423ac290fcc0fe6c77c6
sha256sums = 00165fa765f95ad0a99df2744401b7892384601f70a98d6d0097144cb55f9d68
diff --git a/PKGBUILD b/PKGBUILD
index e7ad81df0dbe..69cba118d872 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
-# Maintainer: T.J. Townsend <blakkheim@archlinux.org>
+# Maintainer: Edmund Lodewijks <e.lodewijks@gmail.com>
+# Contributor: T.J. Townsend <blakkheim@archlinux.org>
# Contributor: Yuuta Liang <yuuta@yuuta.moe>
pkgname=openbgpd
-pkgver=7.5
-pkgrel=3
+pkgver=8.4
+pkgrel=1
pkgdesc="A FREE implementation of the Border Gateway Protocol, Version 4"
arch=(x86_64)
url="https://www.openbgpd.org"
license=('ISC')
-depends=(libevent)
+depends=('libevent' 'libmnl')
source=(https://cdn.openbsd.org/pub/OpenBSD/OpenBGPD/openbgpd-${pkgver}.tar.gz{,.asc}
bgpd.service
sysusers.conf)
-sha256sums=('67a81b3005cb23416b1c4842f1a1ed63a113c26ef1e91ce9ec0b90dcd5caffea'
+changelog=openbgpd.changelog
+sha256sums=('59c107243d4b5133d7be4d75906af57690882bed58134bc066b7b304993848ed'
'SKIP'
'374fbf93489ba8e5d8722c534e5c899a6c01601d5540423ac290fcc0fe6c77c6'
'00165fa765f95ad0a99df2744401b7892384601f70a98d6d0097144cb55f9d68')
diff --git a/openbgpd.changelog b/openbgpd.changelog
new file mode 100644
index 000000000000..65e38785bdaf
--- /dev/null
+++ b/openbgpd.changelog
@@ -0,0 +1,89 @@
+## 8.4 - 2024-03-07
+ * Rewrite the internal message passing mechanism to use a new
+ memory-safe API.
+
+ * Rewrite most protocol parsers to use the new memory-safe API.
+ Convert the UPDATE parser, all of RTR, as well as both the MRT
+ dump code in bgpd and the parser in bgpctl.
+
+ * Improve RTR logging, error handling and version negotiation.
+
+ * Switch to autoconf 2.71 to generate the supplied configure scripts.
+
+
+## 8.3 - 2023-10-13
+ * bgpd 8.1 and 8.2 could send a bad COMMUNITY attribute when
+ non-transitive ext-communities are present. A workaround is to
+ add a filter rule to clear non-transitive ext-communities:
+ match to ebgp set ext-community delete ovs *
+ This fix is included in OpenBSD 7.4.
+
+ * Fix a possible fatal error in the RDE when "announce add-path send all"
+ is used. The error is triggered by an ineligible path which is wrongly
+ distributed.
+
+ * Fix selection of the local nexthop for the alternate address family.
+ This is used by 'announce IPv6 unicast' over an IPv4 session or
+ vice-versa.
+
+
+## 8.2 - 2023-10-02
+ * Update ASPA support to follow draft-ietf-sidrops-aspa-verification-16
+ and draft-ietf-sidrops-aspa-profile-16 by making the ASPA lookup
+ tables AFI-agnostic.
+
+ * Fix a fatal error in the Linux netlink parser which was triggered
+ because of a mismatched netlink message size.
+
+ * Rework UPDATE message generation to use the new ibuf API instead
+ of the hand-rolled solution before.
+
+ * Improve error message in bgpctl for features not supported by the
+ portable version of OpenBGPD.
+
+ * Adjusted example GRACEFUL_SHUTDOWN filter rule in the example config
+ to only match on ebgp sessions.
+
+## 8.1 - 2023-07-12
+ * Include OpenBSD 7.3 errata 002:
+ Avoid fatal errors in bgpd(8) due to incorrect refcounting and
+ mishandling of ASPA objects. Fix bgpctl(8) 'show rib in' by renaming
+ 'invalid' into 'disqualified'.
+
+ * Include OpenBSD 7.3 errata 006:
+ Incorrect length handling of path attributes in bgpd(8) can lead to a
+ session reset.
+
+ * Include OpenBSD 7.3 errata 009:
+ When tracking nexthops over IPv6 multipath routes, or when receiving
+ a NOTIFICATION while reaching an internal limit, bgpd(8) could crash.
+
+ When checking the next hop for IPv6 multipath routes, or when receiving
+ a NOTIFICATION while reaching an internal limit, bgpd(8) could crash.
+
+ * Add configure options to adjust WWW_USER and wwwrunstatedir.
+
+ * Fix 'ext-community * *' matching which also affects filters removing
+ all ext-commuinites.
+
+ * Limit the socket buffer size to 64k for all sessions.
+ Limiting the buffer size to a reasonable size ensures that not too many
+ updates end up queued in the TCP stack.
+
+
+## 8.0 - 2023-05-04
+ * Include OpenBSD 7.3 errata 001 (link: https://www.openbsd.org/errata73.html#p001_bgpd):
+ A new ASPA object appeared in the RPKI ecosystem and exposed bugs in
+ bgpd(8) and rpki-client(8).
+
+ * Introduce a semaphore to protect intermittent RTR session data
+ from being published to the RDE.
+
+ * Add first version of flowspec support. Right now only announcement
+ of flowspec rules is possible.
+
+ * Improve and extend the bgpctl parser to handle commands like
+ `bgpctl show rib 192.0.2.0/24 detail`. Also add various flowspec
+ specific commands.
+
+## This document contains the changelogs as posted in each release announcement on the OpenBSD mailing list.