summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d62d1bef7c29..2fa39d48377c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
- pkgver = 0.3.11
- pkgrel = 2
+ pkgver = 0.3.12
+ pkgrel = 1
url = http://www.openblas.net/
arch = x86_64
license = BSD
@@ -19,8 +19,8 @@ pkgbase = openblas-lapack
conflicts = cblas
conflicts = lapacke
options = !emptydirs
- source = OpenBLAS-0.3.11.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.3.11.tar.gz
- sha256sums = bc4617971179e037ae4e8ebcd837e46db88422f7b365325bd7aba31d1921a673
+ source = OpenBLAS-0.3.12.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.3.12.tar.gz
+ sha256sums = 65a7d3a4010a4e3bd5c0baa41a234797cd3a1735449a4a5902129152601dc57b
pkgname = openblas-lapack
diff --git a/PKGBUILD b/PKGBUILD
index ce9366da3aec..5220d699e1aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
pkgname=openblas-lapack
_PkgName=OpenBLAS
_pkgname=openblas
-pkgver=0.3.11
+pkgver=0.3.12
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.9.0
_blasver=3.8.0
-pkgrel=2
+pkgrel=1
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('x86_64')
url="http://www.openblas.net/"
@@ -21,7 +21,7 @@ provides=('openblas' "blas=${_blasver}" "lapack=${_lapackver}" "cblas=${_blasver
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz)
-sha256sums=('bc4617971179e037ae4e8ebcd837e46db88422f7b365325bd7aba31d1921a673')
+sha256sums=('65a7d3a4010a4e3bd5c0baa41a234797cd3a1735449a4a5902129152601dc57b')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
@@ -33,7 +33,7 @@ _config="FC=gfortran USE_OPENMP=1 USE_THREAD=1 \
build(){
cd "${srcdir}/${_PkgName}-${pkgver}"
- make ${_config} CFLAGS="${CFLAGS} -march=native" libs netlib shared
+ make ${_config} CFLAGS="${CFLAGS}" libs netlib shared
}
check(){