summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 3 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb5b3dd8544c..b5cc31caf7af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
pkgver = 0.2.14
- pkgrel = 4
+ pkgrel = 5
url = http://xianyi.github.com/OpenBLAS/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b928d7836a63..0f42ba792016 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openblas-lapack
_pkgname=OpenBLAS
pkgver=0.2.14
-pkgrel=4
+pkgrel=5
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('i686' 'x86_64')
url="http://xianyi.github.com/OpenBLAS/"
@@ -23,11 +23,7 @@ _config="FC=gfortran USE_OPENMP=0 USE_THREAD=1 MAJOR_VERSION=3 NO_LAPACK=0"
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- NPROC=`grep "physical id" /proc/cpuinfo|sort|uniq|wc -l`
- NCORE4PROC=`grep "cores" /proc/cpuinfo|sort|tail -n 1|sed -e 's/cpu cores.*: //'`
- let NCORE=NPROC*NCORE4PROC
-
- make ${_config} NUM_THREADS=${NCORE} libs netlib shared
+ make ${_config} libs netlib shared
}
check() {