summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8730ee848cd6..786aa5763db5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
pkgver = 0.3.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.openblas.net/
arch = any
license = BSD
@@ -20,7 +20,9 @@ pkgbase = openblas-lapack
conflicts = lapacke
options = !emptydirs
source = OpenBLAS-0.3.2.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.3.2.tar.gz
+ source = https://salsa.debian.org/science-team/openblas/raw/e51b3b26641901a5a93247ef9bb9dbdddc82cfae/debian/patches/0008-Allow-overriding-USE_COMPILER_TLS-formerly-HAS_COMPI.patch
sha256sums = e8ba64f6b103c511ae13736100347deb7121ba9b41ba82052b1a018a65c0cb15
+ sha256sums = f3384c96f9572fd8f0173d10ca2d0233f674780e881865e4b8dbc7d0354738f5
pkgname = openblas-lapack
diff --git a/.gitignore b/.gitignore
index b3e266f37fb2..f82ac8a062b6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@
*.xz
/pkg
/src
+0008-Allow-overriding-USE_COMPILER_TLS-formerly-HAS_COMPI.patch
*.log*
diff --git a/PKGBUILD b/PKGBUILD
index bdccdcc65c8c..58b36791e3c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _pkgname=openblas
pkgver=0.3.2
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('any')
url="http://www.openblas.net/"
@@ -18,14 +18,22 @@ makedepends=('perl' 'gcc-fortran')
provides=('openblas' "blas=${_lapackver}" "lapack=${_lapackver}" "cblas=${_lapackver}" "lapacke=${_lapackver}")
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
-source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz)
-sha256sums=('e8ba64f6b103c511ae13736100347deb7121ba9b41ba82052b1a018a65c0cb15')
+source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz
+ https://salsa.debian.org/science-team/openblas/raw/e51b3b26641901a5a93247ef9bb9dbdddc82cfae/debian/patches/0008-Allow-overriding-USE_COMPILER_TLS-formerly-HAS_COMPI.patch)
+sha256sums=('e8ba64f6b103c511ae13736100347deb7121ba9b41ba82052b1a018a65c0cb15'
+ 'f3384c96f9572fd8f0173d10ca2d0233f674780e881865e4b8dbc7d0354738f5')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
_config="FC=gfortran USE_OPENMP=0 USE_THREAD=1 \
NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1"
+prepare (){
+ cd "${srcdir}/${_PkgName}-${pkgver}"
+
+ patch -p1 < "${srcdir}/0008-Allow-overriding-USE_COMPILER_TLS-formerly-HAS_COMPI.patch"
+}
+
build(){
cd "${srcdir}/${_PkgName}-${pkgver}"