summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD6
-rw-r--r--strict_skip_taskbar.patch18
2 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba6dd8147736..7bbb8cb05b27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alexey Korop <akorop@ukr.net>
pkgname=openbox_eui
-pkgver=2015.11.06
-pkgrel=2
+pkgver=2016.03.08
+pkgrel=1
pkgdesc='Highly configurable and lightweight X11 window manager'
arch=('i686' 'x86_64')
url='http://openbox.org'
@@ -50,7 +50,7 @@ md5sums=(
'3718f41d8573d5d2a4cf04536562b93a'
'6579e6898e3195fb6877e356b2092bba'
'fabc9f22ebdda17649b7c98fd8fc4d81'
- 'e6a16b0be7eac066976fc56ed0bd1b27'
+ 'b480d2825212fa73d9444453e36ed661'
'5556e7accb519b922b2d07bc0bb67447'
'1ea5cf52cc72fd7b18f50798d1458baf'
'e2e2480a2dfe13e93de5fa88c17eaa77'
diff --git a/strict_skip_taskbar.patch b/strict_skip_taskbar.patch
index 3ffc16a41042..a766d1f28452 100644
--- a/strict_skip_taskbar.patch
+++ b/strict_skip_taskbar.patch
@@ -1,14 +1,8 @@
-commit 3600f9b81b7987d4f777d6218e23e7b2764878ae
-Author: Alexey Korop <avkorop@i.ua>
-Date: Tue Mar 31 20:30:28 2015 +0300
-
- strict_skip_taskbar
-
diff --git a/openbox/config.c b/openbox/config.c
-index 5d2408f..81b542c 100644
+index dad5d1b..0e0d1f9 100644
--- a/openbox/config.c
+++ b/openbox/config.c
-@@ -49,6 +49,7 @@ StrutPartial config_margins;
+@@ -48,6 +48,7 @@ StrutPartial config_margins;
gchar *config_theme;
gboolean config_theme_keepborder;
guint config_theme_window_list_icon_size;
@@ -16,17 +10,17 @@ index 5d2408f..81b542c 100644
gchar *config_title_layout;
-@@ -735,6 +736,8 @@ static void parse_theme(xmlNodePtr node, gpointer d)
- config_theme_window_list_icon_size = 16;
+@@ -719,6 +720,8 @@ static void parse_theme(xmlNodePtr node, gpointer d)
else if (config_theme_window_list_icon_size > 96)
config_theme_window_list_icon_size = 96;
+ }
+ if ((n = obt_xml_find_node(node, "strictSkipTaskbar")))
+ config_theme_strict_skip_taskbar = obt_xml_node_bool(n);
- }
for (n = obt_xml_find_node(node, "font");
+ n;
diff --git a/openbox/config.h b/openbox/config.h
-index e70ccab..45f8adf 100644
+index 96a66cf..4e6e88e 100644
--- a/openbox/config.h
+++ b/openbox/config.h
@@ -152,6 +152,8 @@ extern gchar *config_title_layout;