summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--opencpn.install15
-rw-r--r--plugin.patch25
4 files changed, 61 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bff254665175..8be7c282d9ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,27 @@
pkgbase = opencpn
pkgdesc = Open Source Chart Plotting / Marine Navigation
- pkgver = 5.2.0
- pkgrel = 2
+ pkgver = 5.8.4
+ pkgrel = 1
url = http://opencpn.org
- install = opencpn.install
arch = x86_64
+ arch = aarch64
license = GPL2
makedepends = cmake
+ makedepends = lsb-release
depends = wxgtk3
- depends = gpsd
depends = portaudio
depends = tinyxml
- depends = hicolor-icon-theme
+ depends = libsndfile
+ depends = libarchive
+ depends = libexif
+ depends = glew
+ depends = glu
depends = webkit2gtk
- source = https://github.com/OpenCPN/OpenCPN/archive/v5.2.0.tar.gz
- sha1sums = 352037909fde8a7195f740ed6a0f8d1eff8e9e78
+ depends = wxsvg
+ optdepends = gpsd: GPS position support
+ source = opencpn-5.8.4.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/Release_5.8.4.tar.gz
+ source = plugin.patch
+ b2sums = 0235d87daec97008b58dc9916d4250b33c0c4158be6ba4853bf30c5876af7d382eb1c02e2cd3748229775305cc90f86d5743b9951909043588e2096fcd207af5
+ b2sums = 66a83b2ef79ce903884d1d072a5e4f8c6db557b2566fa1c50b82b4435cdbf787116c6b9f6d590e9240ca0c8bc06794ac5d9245e7ef18a2c03869f808c51582a6
pkgname = opencpn
-
diff --git a/PKGBUILD b/PKGBUILD
index e07ba5b42e6d..1781e238d8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,38 @@
-# Maintainer: trougnouf (Benoit Brummer) <trougnouf at gmail dot com>
+# Maintainer: cybuzuma <cybuzuma at vnxs dot de>
+# Contributor: trougnouf (Benoit Brummer) <trougnouf at gmail dot com>
+# Contributor: Romain Bazile <gromain.baz@gmail.com>
# Contributor: Bruno Rodriguez (brunorro)
# Contributor: Øyvind 'Mr.Elendig' Heggstad <mrelendig at har-ikkje dot net>
# Contributor: Travis Fickett <tfickett AT ufl DOT edu>
# Submitter: Anders Lund <anders at alweb dot dk>
pkgname=opencpn
-_name="OpenCPN"
-pkgver=5.2.0
-pkgrel=2
+pkgver=5.8.4
+pkgrel=1
pkgdesc="Open Source Chart Plotting / Marine Navigation"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
license=("GPL2")
-depends=('wxgtk3' 'gpsd' 'portaudio' 'tinyxml' 'hicolor-icon-theme' 'webkit2gtk')
-makedepends=('cmake')
+depends=('wxgtk3' 'portaudio' 'tinyxml' 'libsndfile' 'libarchive' 'libexif' 'glew' 'glu' 'webkit2gtk' 'wxsvg')
+optdepends=('gpsd: GPS position support')
+makedepends=('cmake' 'lsb-release')
url="http://opencpn.org"
-install=opencpn.install
-source=("https://github.com/${_name}/${_name}/archive/v${pkgver}.tar.gz")
-sha1sums=('352037909fde8a7195f740ed6a0f8d1eff8e9e78')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/Release_${pkgver}.tar.gz" "plugin.patch")
+b2sums=('0235d87daec97008b58dc9916d4250b33c0c4158be6ba4853bf30c5876af7d382eb1c02e2cd3748229775305cc90f86d5743b9951909043588e2096fcd207af5' '66a83b2ef79ce903884d1d072a5e4f8c6db557b2566fa1c50b82b4435cdbf787116c6b9f6d590e9240ca0c8bc06794ac5d9245e7ef18a2c03869f808c51582a6')
+
+prepare() {
+ cd OpenCPN-Release_${pkgver}
+ patch --strip=1 --input=../plugin.patch
+}
build() {
- cd "OpenCPN-${pkgver}"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUNDLE_GSHHS=CRUDE -DBUNDLE_TCDATA=ON -DBUNDLE_DOCS=ON \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
- -DOCPN_FORCE_GTK3=ON
+ cd OpenCPN-Release_${pkgver}
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DOCPN_BUILD_TEST=OFF -DOCPN_VERBOSE=OFF -DOCPN_USE_EXTERN_CURL=ON ..
make
}
package() {
- cd "OpenCPN-${pkgver}"
+ cd OpenCPN-Release_${pkgver}/build
make DESTDIR="$pkgdir" install
}
diff --git a/opencpn.install b/opencpn.install
deleted file mode 100644
index 0a039b4dd254..000000000000
--- a/opencpn.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
diff --git a/plugin.patch b/plugin.patch
new file mode 100644
index 000000000000..e9b70963650e
--- /dev/null
+++ b/plugin.patch
@@ -0,0 +1,25 @@
+--- a/src/plugin_loader.cpp
++++ b/src/plugin_loader.cpp
+@@ -317,14 +317,14 @@
+ if (!base_plugin_path.EndsWith(wxFileName::GetPathSeparator()))
+ base_plugin_path += wxFileName::GetPathSeparator();
+
+- if (!g_bportable){
+- if (base_plugin_path.IsSameAs(plugin_file_path)){
+- if (!IsSystemPlugin(file_name.ToStdString())){
+- DEBUG_LOG << "Skipping plugin " << file_name << " in " << g_BasePlatform->GetPluginDir();
+- return false;
+- }
+- }
+- }
++ // if (!g_bportable){
++ // if (base_plugin_path.IsSameAs(plugin_file_path)){
++ // if (!IsSystemPlugin(file_name.ToStdString())){
++ // DEBUG_LOG << "Skipping plugin " << file_name << " in " << g_BasePlatform->GetPluginDir();
++ // return false;
++ // }
++ // }
++ // }
+
+ if (!IsSystemPlugin(file_name.ToStdString()) && safe_mode::get_mode()) {
+ DEBUG_LOG << "Skipping plugin " << file_name << " in safe mode";