summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--fix-java-lib-path.patch13
3 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e9981e9df80..b25ef00e6881 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opencv2-opt
pkgdesc = Open Source Computer Vision Library (Legacy Version & /opt directory version)
pkgver = 2.4.13.6
- pkgrel = 1
+ pkgrel = 2
url = http://opencv.org/
arch = i686
arch = x86_64
@@ -20,7 +20,9 @@ pkgbase = opencv2-opt
optdepends = libcl: For coding with OpenCL
optdepends = python2-numpy: Python 2.x interface
source = opencv-2.4.13.6.zip::https://github.com/Itseez/opencv/archive/2.4.13.6.zip
+ source = fix-java-lib-path.patch
sha512sums = 942a523192ac790bc8184dff3b7652efd92dfe786091402a7686a468ae567e1c09b9205e6c56424602a887057a57c31a0b0e4f4f9ca29c1b1856024b8d9ad990
+ sha512sums = 111d2f8407a3937acabd8c60f7d77408aadf9d8acf621ddb2b4312f39155ce14d6c764e7ac36905c90eb279bf7803e30def39e52807adb7516325b7c3adac65e
pkgname = opencv2-opt
provides = opencv2
diff --git a/PKGBUILD b/PKGBUILD
index 105503e50df5..e53fa22ec958 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,7 +41,7 @@ _FORCE_AVX2=OFF
pkgbase=opencv2-opt
pkgname=('opencv2-opt' 'opencv2-opt-samples')
pkgver=2.4.13.6
-pkgrel=1
+pkgrel=2
_pkgbase=opencv2
_pkgname=opencv
pkgdesc="Open Source Computer Vision Library (Legacy Version & /opt directory version)"
@@ -55,9 +55,12 @@ optdepends=('opencv2-opt-samples'
'libcl: For coding with OpenCL'
'python2-numpy: Python 2.x interface')
-source=("$_pkgname-$pkgver.zip::https://github.com/Itseez/opencv/archive/$pkgver.zip"
- )
-sha512sums=('942a523192ac790bc8184dff3b7652efd92dfe786091402a7686a468ae567e1c09b9205e6c56424602a887057a57c31a0b0e4f4f9ca29c1b1856024b8d9ad990')
+source=(
+ "$_pkgname-$pkgver.zip::https://github.com/Itseez/opencv/archive/$pkgver.zip"
+ 'fix-java-lib-path.patch'
+)
+sha512sums=('942a523192ac790bc8184dff3b7652efd92dfe786091402a7686a468ae567e1c09b9205e6c56424602a887057a57c31a0b0e4f4f9ca29c1b1856024b8d9ad990'
+ '111d2f8407a3937acabd8c60f7d77408aadf9d8acf621ddb2b4312f39155ce14d6c764e7ac36905c90eb279bf7803e30def39e52807adb7516325b7c3adac65e')
_cmakeopts=('-D WITH_CUDA=OFF' # Disable CUDA for now because GCC 6.1.1 and nvcc don't play along yet
'-D WITH_OPENCL=ON'
@@ -96,6 +99,7 @@ prepare() {
sed "1i\#define AVFMT_RAWPICTURE 0x0020" -i modules/highgui/src/cap_ffmpeg_impl.hpp
sed "1i\#define CODEC_FLAG_GLOBAL_HEADER AV_CODEC_FLAG_GLOBAL_HEADER" -i modules/highgui/src/cap_ffmpeg_impl.hpp
sed "1i\#define AV_CODEC_FLAG_GLOBAL_HEADER (1 << 22)" -i modules/highgui/src/cap_ffmpeg_impl.hpp
+ patch -Np1 -i ${srcdir}/fix-java-lib-path.patch
}
build() {
@@ -124,8 +128,9 @@ package_opencv2-opt() {
cd "$pkgdir/opt/$_pkgbase/share"
# separate samples package; also be -R friendly
if [[ -d OpenCV/samples ]]; then
+ mkdir -p $_pkgbase
mv OpenCV/samples "$srcdir/$_pkgbase-samples"
- mv OpenCV $_pkgbase # otherwise folder naming is inconsistent
+ mv OpenCV/* $_pkgbase # otherwise folder naming is inconsistent
elif [[ ! -d OpenCV ]]; then
warning "Directory naming issue; samples package may not be built!"
fi
diff --git a/fix-java-lib-path.patch b/fix-java-lib-path.patch
new file mode 100644
index 000000000000..25a857216082
--- /dev/null
+++ b/fix-java-lib-path.patch
@@ -0,0 +1,13 @@
+diff --git a/modules/java/CMakeLists.txt b/modules/java/CMakeLists.txt
+index c46f70a..b7c152e 100644
+--- a/modules/java/CMakeLists.txt
++++ b/modules/java/CMakeLists.txt
+@@ -280,7 +280,7 @@ else(ANDROID)
+ if(WIN32)
+ set(JAR_INSTALL_DIR java)
+ else(WIN32)
+- set(JAR_INSTALL_DIR share/OpenCV/java)
++ set(JAR_INSTALL_DIR share/opencv2/java)
+ endif(WIN32)
+ install(FILES ${JAR_FILE} DESTINATION ${JAR_INSTALL_DIR} COMPONENT java)
+ endif(ANDROID)