summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD74
-rw-r--r--STLsurfaceFormatASCII_L.patch11
-rw-r--r--ansysToFoam_L.patch11
-rw-r--r--decomposePar_options.patch9
-rw-r--r--fluent3DMeshToFoam_L.patch11
-rw-r--r--fluentMeshToFoam_L.patch11
-rw-r--r--gambitToFoam_L.patch11
-rw-r--r--paraFoam.patch49
-rw-r--r--readSTLASCII_L.patch11
-rw-r--r--renumberMesh_options.patch10
11 files changed, 202 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 782ed512af10..835a60e11099 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Sun Dec 13 00:28:56 UTC 2015
+# Tue Jan 19 20:17:32 UTC 2016
pkgbase = openfoam
pkgdesc = The open source CFD toolbox
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 2
- url = http://www.openfoam.com
+ url = http://www.openfoam.org
install = openfoam.install
arch = any
license = GPL
@@ -15,8 +15,26 @@ pkgbase = openfoam
depends = boost
depends = flex
depends = cgal
- source = http://downloads.sourceforge.net/foam/OpenFOAM-3.0.0.tgz
- md5sums = fefa399a5c0cbe33fbabb65be17ea617
+ source = http://downloads.sourceforge.net/foam/OpenFOAM-3.0.1.tgz
+ source = paraFoam.patch
+ source = readSTLASCII_L.patch
+ source = ansysToFoam_L.patch
+ source = STLsurfaceFormatASCII_L.patch
+ source = renumberMesh_options.patch
+ source = decomposePar_options.patch
+ source = gambitToFoam_L.patch
+ source = fluent3DMeshToFoam_L.patch
+ source = fluentMeshToFoam_L.patch
+ md5sums = 304e6a14b9e69c20989527f5fb1ed724
+ md5sums = 352b06d5c1f42eceff784b9130bfe444
+ md5sums = 1f1850ac3d005baa6039b5dca5780e55
+ md5sums = 23dc21fb55ffc6cfbc8dd5dca903ab22
+ md5sums = 285cdc4cd6039da598156fa405e31d29
+ md5sums = 815ba1f4df3c40b298e31c57738acd93
+ md5sums = 029a20598e565da2638441aa0c39ff74
+ md5sums = be0952767725ff63115f73064a594b35
+ md5sums = a3f8054fe234e18bc2f831d6c23f9abd
+ md5sums = 7ab2085baeb8393d4bf7b418658612a9
pkgname = openfoam
diff --git a/PKGBUILD b/PKGBUILD
index cb1838236d87..e333d06f81d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,30 +7,37 @@ pkgname=openfoam
# The distributors package name
_distpkgname=OpenFOAM
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=2
pkgdesc="The open source CFD toolbox"
arch=("any")
-url="http://www.openfoam.com"
+url="http://www.openfoam.org"
license=("GPL")
depends=('bzip2' 'paraview' 'parmetis' 'scotch' 'boost' 'flex' 'cgal')
-source=("http://downloads.sourceforge.net/foam/${_distpkgname}-${pkgver}.tgz")
-# "decomp-options.patch"
-# "paraFoam.patch"
-# "scotch-options.patch"
-# "settings.patch")
+source=("http://downloads.sourceforge.net/foam/${_distpkgname}-${pkgver}.tgz"
+ "paraFoam.patch"
+ "readSTLASCII_L.patch"
+ "ansysToFoam_L.patch"
+ "STLsurfaceFormatASCII_L.patch"
+ "renumberMesh_options.patch"
+ "decomposePar_options.patch"
+ "gambitToFoam_L.patch"
+ "fluent3DMeshToFoam_L.patch"
+ "fluentMeshToFoam_L.patch")
+
install="${pkgname}.install"
-#sha256sums=('SKIP'
-# '3faef066228df77bad5b329bf251fc057dc5dac3b749d5bcd292438f89a546b7'
-# 'cdd8c599f34cc967e6fb75b7da5f337aa7b56b19cf0871ebf608af6507abe07c'
-# 'bbf370e411dc7fd95c3d823dac3534d4312fe90c0365b596aa2a3ed016463819'
-# '9f36415505d71d86a7f18624f8ed9888f8fa7af09833b0dd215477ddca57302f')
-
-md5sums=('fefa399a5c0cbe33fbabb65be17ea617')
-# 'SKIP'
-# 'SKIP'
-# 'SKIP'
-# 'SKIP')
+
+md5sums=('304e6a14b9e69c20989527f5fb1ed724'
+ '352b06d5c1f42eceff784b9130bfe444'
+ '1f1850ac3d005baa6039b5dca5780e55'
+ '23dc21fb55ffc6cfbc8dd5dca903ab22'
+ '285cdc4cd6039da598156fa405e31d29'
+ '815ba1f4df3c40b298e31c57738acd93'
+ '029a20598e565da2638441aa0c39ff74'
+ 'be0952767725ff63115f73064a594b35'
+ 'a3f8054fe234e18bc2f831d6c23f9abd'
+ '7ab2085baeb8393d4bf7b418658612a9')
+
prepare() {
# Extract the current version and major of paraview and of scotch for use in the system preferences
@@ -43,30 +50,38 @@ prepare() {
echo "export WM_MPLIB=SYSTEMOPENMPI" >> ${srcdir}/prefs.sh
echo "export ParaView_VERSION=${_pversion}" >> ${srcdir}/prefs.sh
echo "export ParaView_MAJOR=${_pmajor}" >> ${srcdir}/prefs.sh
- cp ${srcdir}/prefs.sh ${srcdir}/${_distpkgname}-${pkgver}/etc || return 1
+ cp ${srcdir}/prefs.sh ${srcdir}/${_distpkgname}-${pkgver}/etc #|| return 1
# Generate the scotch.sh file for arch
echo "export SCOTCH_VERSION=scotch_${_sversion}" > ${srcdir}/scotch.sh
echo "export SCOTCH_ARCH_PATH=/usr" >> ${srcdir}/scotch.sh
- cp ${srcdir}/scotch.sh ${srcdir}/${_distpkgname}-${pkgver}/etc/config || return 1
+ cp ${srcdir}/scotch.sh ${srcdir}/${_distpkgname}-${pkgver}/etc/config #|| return 1
# Patch for archlinux parmetis, paraview and openmpi paths, and scotch link lines
#patch -p1 < ${srcdir}/decomp-options.patch
- #patch -p1 < ${srcdir}/paraFoam.patch
+ patch -p1 < ${srcdir}/paraFoam.patch
#patch -p1 < ${srcdir}/scotch-options.patch
+ patch -p1 < ${srcdir}/readSTLASCII_L.patch
+ patch -p1 < ${srcdir}/ansysToFoam_L.patch
+ patch -p1 < ${srcdir}/STLsurfaceFormatASCII_L.patch
+ patch -p1 < ${srcdir}/renumberMesh_options.patch
+ patch -p1 < ${srcdir}/decomposePar_options.patch
+ patch -p1 < ${srcdir}/gambitToFoam_L.patch
+ patch -p1 < ${srcdir}/fluent3DMeshToFoam_L.patch
+ patch -p1 < ${srcdir}/fluentMeshToFoam_L.patch
}
build() {
# Setup the build environment
export FOAM_INST_DIR=${srcdir}
foamDotFile=${srcdir}/${_distpkgname}-${pkgver}/etc/bashrc
- [ -f ${foamDotFile} ] && . ${foamDotFile} || return 1
+ [ -f ${foamDotFile} ] && . ${foamDotFile} #|| return 1
# Enter build directory
- cd ${srcdir}/${_distpkgname}-${pkgver} || return 1
+ cd ${srcdir}/${_distpkgname}-${pkgver} #|| return 1
# Build and clean up OpenFOAM
- ./Allwmake || return 1
+ ./Allwmake > ../../openfoam_log.make 2>&1 #|| return 1
wclean all || return 1
}
@@ -76,13 +91,14 @@ package() {
# Create destination directories
install -d ${pkgdir}/opt/${_distpkgname} ${pkgdir}/etc/profile.d || return 1
- # Move package to pkgdir
- mv ${srcdir}/${_distpkgname}-${pkgver} ${pkgdir}/opt/${_distpkgname} || return 1
+ # copy package to pkgdir
+ cp -r ${srcdir}/${_distpkgname}-${pkgver} ${pkgdir}/opt/${_distpkgname} || return 1
# Add source file
- echo "export FOAM_INST_DIR=/opt/${_distpkgname}" > ${pkgdir}/etc/profile.d/openfoam.sh || return 1
- echo "alias ofoam=\"source \${FOAM_INST_DIR}/${_distpkgname}-${pkgver}/etc/bashrc\"" >> ${pkgdir}/etc/profile.d/openfoam.sh || return 1
-
+ echo "export FOAM_INST_DIR=/opt/${_distpkgname}" > ${pkgdir}/etc/profile.d/openfoam-${pkgver}.sh || return 1
+ echo "alias ofoam=\"source \${FOAM_INST_DIR}/${_distpkgname}-${pkgver}/etc/bashrc\"" >> ${pkgdir}/etc/profile.d/openfoam-${pkgver}.sh || return 1
+ chmod 755 ${pkgdir}/etc/profile.d/openfoam-${pkgver}.sh || return 1
+
# Add stub thirdparty directory to keep openfoam happy
install -d ${pkgdir}/opt/${_distpkgname}/ThirdParty-${pkgver} || return 1
diff --git a/STLsurfaceFormatASCII_L.patch b/STLsurfaceFormatASCII_L.patch
new file mode 100644
index 000000000000..33596119afb7
--- /dev/null
+++ b/STLsurfaceFormatASCII_L.patch
@@ -0,0 +1,11 @@
+--- src/OpenFOAM-3.0.1/src/surfMesh/surfaceFormats/stl/STLsurfaceFormatASCII.L
++++ src/OpenFOAM-3.0.1/src/surfMesh/surfaceFormats/stl/STLsurfaceFormatASCII.L
+@@ -50,7 +50,7 @@
+ // It is called by yylex but is not used as the mechanism to change file.
+ // See <<EOF>>
+ //! \cond dummy
+-#if YY_FLEX_SUBMINOR_VERSION < 34
++#if YY_FLEX_SUBMINOR_VERSION < 34 && YY_FLEX_MINOR_VERSION < 6
+ extern "C" int yywrap()
+ #else
+ int yyFlexLexer::yywrap()
diff --git a/ansysToFoam_L.patch b/ansysToFoam_L.patch
new file mode 100644
index 000000000000..d2eb994528ce
--- /dev/null
+++ b/ansysToFoam_L.patch
@@ -0,0 +1,11 @@
+--- src/OpenFOAM-3.0.1/applications/utilities/mesh/conversion/ansysToFoam/ansysToFoam.L
++++ src/OpenFOAM-3.0.1/applications/utilities/mesh/conversion/ansysToFoam/ansysToFoam.L
+@@ -77,7 +77,7 @@
+ // Dummy yywrap to keep yylex happy at compile time.
+ // It is called by yylex but is not used as the mechanism to change file.
+ // See <<EOF>>
+-#if YY_FLEX_SUBMINOR_VERSION < 34
++#if YY_FLEX_SUBMINOR_VERSION < 34 && YY_FLEX_MINOR_VERSION < 6
+ extern "C" int yywrap()
+ #else
+ int yyFlexLexer::yywrap()
diff --git a/decomposePar_options.patch b/decomposePar_options.patch
new file mode 100644
index 000000000000..088cfc8e1339
--- /dev/null
+++ b/decomposePar_options.patch
@@ -0,0 +1,9 @@
+--- src/OpenFOAM-3.0.1/applications/utilities/parallelProcessing/decomposePar/Make/options
++++ src/OpenFOAM-3.0.1/applications/utilities/parallelProcessing/decomposePar/Make/options
+@@ -13,4 +13,5 @@ EXE_LIBS = \
+ -ldecompositionMethods -L$(FOAM_LIBBIN)/dummy -lmetisDecomp -lscotchDecomp \
+ -llagrangian \
+ -lmeshTools \
+- -lregionModels
++ -lregionModels \
++ -lbz2
diff --git a/fluent3DMeshToFoam_L.patch b/fluent3DMeshToFoam_L.patch
new file mode 100644
index 000000000000..d7b7edc5871e
--- /dev/null
+++ b/fluent3DMeshToFoam_L.patch
@@ -0,0 +1,11 @@
+--- src/OpenFOAM-3.0.1/applications/utilities/mesh/conversion/fluent3DMeshToFoam/fluent3DMeshToFoam.L
++++ src/OpenFOAM-3.0.1/applications/utilities/mesh/conversion/fluent3DMeshToFoam/fluent3DMeshToFoam.L
+@@ -123,7 +123,7 @@
+ // Dummy yywrap to keep yylex happy at compile time.
+ // It is called by yylex but is not used as the mechanism to change file.
+ // See <<EOF>>
+-#if YY_FLEX_SUBMINOR_VERSION < 34
++#if YY_FLEX_SUBMINOR_VERSION < 34 && YY_FLEX_MINOR_VERSION < 6
+ extern "C" int yywrap()
+ #else
+ int yyFlexLexer::yywrap()
diff --git a/fluentMeshToFoam_L.patch b/fluentMeshToFoam_L.patch
new file mode 100644
index 000000000000..4b27ce044e1e
--- /dev/null
+++ b/fluentMeshToFoam_L.patch
@@ -0,0 +1,11 @@
+--- src/OpenFOAM-3.0.1/applications/utilities/mesh/conversion/fluentMeshToFoam/fluentMeshToFoam.L
++++ src/OpenFOAM-3.0.1/applications/utilities/mesh/conversion/fluentMeshToFoam/fluentMeshToFoam.L
+@@ -100,7 +100,7 @@
+ // Dummy yywrap to keep yylex happy at compile time.
+ // It is called by yylex but is not used as the mechanism to change file.
+ // See <<EOF>>
+-#if YY_FLEX_SUBMINOR_VERSION < 34
++#if YY_FLEX_SUBMINOR_VERSION < 34 && YY_FLEX_MINOR_VERSION < 6
+ extern "C" int yywrap()
+ #else
+ int yyFlexLexer::yywrap()
diff --git a/gambitToFoam_L.patch b/gambitToFoam_L.patch
new file mode 100644
index 000000000000..47a82cf19dd7
--- /dev/null
+++ b/gambitToFoam_L.patch
@@ -0,0 +1,11 @@
+--- src/OpenFOAM-3.0.1/applications/utilities/mesh/conversion/gambitToFoam/gambitToFoam.L
++++ src/OpenFOAM-3.0.1/applications/utilities/mesh/conversion/gambitToFoam/gambitToFoam.L
+@@ -80,7 +80,7 @@
+ // Dummy yywrap to keep yylex happy at compile time.
+ // It is called by yylex but is not used as the mechanism to change file.
+ // See <<EOF>>
+-#if YY_FLEX_SUBMINOR_VERSION < 34
++#if YY_FLEX_SUBMINOR_VERSION < 34 && YY_FLEX_MINOR_VERSION < 6
+ extern "C" int yywrap()
+ #else
+ int yyFlexLexer::yywrap()
diff --git a/paraFoam.patch b/paraFoam.patch
new file mode 100644
index 000000000000..9a420e30db8e
--- /dev/null
+++ b/paraFoam.patch
@@ -0,0 +1,49 @@
+--- src/OpenFOAM-3.0.1/bin/paraFoam
++++ src/OpenFOAM-3.0.1/bin/paraFoam
+@@ -68,7 +68,7 @@
+ export LC_ALL=C
+
+ # Reader extension
+-extension=OpenFOAM
++extension=foam
+
+ requirePV=1
+
+@@ -124,21 +124,22 @@
+ # Get the ParaView major version to select the appropriate readers
+ version=`echo $ParaView_VERSION | sed -e 's/^\([0-9][0-9]*\).*$/\1/'`
+
+-# Check that reader module has been built
+-if [ $requirePV -eq 1 -a ! -f $PV_PLUGIN_PATH/libPV${version}FoamReader_SM.so ]
+-then
+- cat<< BUILDREADER
+-
+-FATAL ERROR: ParaView reader module libraries do not exist
+-
+-Please build the reader module before continuing:
+-cd \$FOAM_UTILITIES/postProcessing/graphics/PV${version}Readers
+-./Allwclean
+-./Allwmake
+-
+-BUILDREADER
+- exit 1
+-fi
++# NOTE: For OpenFOAM built from AUR, paraview will already be installed
++# with the required readers. No need to perform this check.
++#if [ $requirePV -eq 1 -a ! -f $PV_PLUGIN_PATH/libPV${version}FoamReader_SM.so ]
++#then
++# cat<< BUILDREADER
++#
++#FATAL ERROR: ParaView reader module libraries do not exist
++#
++#Please build the reader module before continuing:
++#cd \$FOAM_UTILITIES/postProcessing/graphics/PV${version}Readers
++#./Allwclean
++#./Allwmake
++#
++#BUILDREADER
++# exit 1
++#fi
+
+ # Check for --data=... argument
+ hasDataArg()
diff --git a/readSTLASCII_L.patch b/readSTLASCII_L.patch
new file mode 100644
index 000000000000..9092aa004298
--- /dev/null
+++ b/readSTLASCII_L.patch
@@ -0,0 +1,11 @@
+--- src/OpenFOAM-3.0.1/src/triSurface/triSurface/interfaces/STL/readSTLASCII.L
++++ src/OpenFOAM-3.0.1/src/triSurface/triSurface/interfaces/STL/readSTLASCII.L
+@@ -55,7 +55,7 @@
+ // It is called by yylex but is not used as the mechanism to change file.
+ // See <<EOF>>
+ //! \cond dummy
+-#if YY_FLEX_SUBMINOR_VERSION < 34
++#if YY_FLEX_SUBMINOR_VERSION < 34 && YY_FLEX_MINOR_VERSION < 6
+ extern "C" int yywrap()
+ #else
+ int yyFlexLexer::yywrap()
diff --git a/renumberMesh_options.patch b/renumberMesh_options.patch
new file mode 100644
index 000000000000..a3b50b5f63c4
--- /dev/null
+++ b/renumberMesh_options.patch
@@ -0,0 +1,10 @@
+--- src/OpenFOAM-3.0.1/applications/utilities/mesh/manipulation/renumberMesh/Make/options
++++ src/OpenFOAM-3.0.1/applications/utilities/mesh/manipulation/renumberMesh/Make/options
+@@ -15,4 +15,5 @@ EXE_LIBS = \
+ -lgenericPatchFields \
+ -lrenumberMethods \
+ $(LINK_FLAGS) \
+- -ldecompositionMethods -L$(FOAM_LIBBIN)/dummy -lmetisDecomp -lscotchDecomp
++ -ldecompositionMethods -L$(FOAM_LIBBIN)/dummy -lmetisDecomp -lscotchDecomp \
++ -lbz2
+