summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD35
-rw-r--r--openframeworks.install4
3 files changed, 34 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12010dc4963e..eb99a16e89ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Dec 14 14:06:55 UTC 2015
pkgbase = openframeworks
pkgdesc = openFrameworks is an open source C++ toolkit for creative coding.
pkgver = 0.9.0
- pkgrel = 1
+ pkgrel = 2
url = http://openframeworks.cc/
install = openframeworks.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5a39f28b5567..7b61e8bd81af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=openframeworks
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="openFrameworks is an open source C++ toolkit for creative coding."
url="http://openframeworks.cc/"
arch=('x86_64' 'i686')
@@ -17,7 +17,7 @@ options=(!strip)
install=openframeworks.install
[[ "$CARCH" == "i686" ]] && _arch="linux" || _arch="linux64"
-_name=of_v${pkgver}_${_arch}_release
+_name="of_v${pkgver}_${_arch}_release"
source=("http://www.openframeworks.cc/versions/v${pkgver}/${_name}.tar.gz" "of-make-workspace")
@@ -25,14 +25,37 @@ source=("http://www.openframeworks.cc/versions/v${pkgver}/${_name}.tar.gz" "of-m
md5sums+=("594d0a3c82e0451f7b7fb353e3b658c6")
+prepare() {
+ export OF_ROOT=${srcdir}/${_name}
+ export LC_ALL=C
+
+ ARCH=$(uname -m)
+
+ if [ "$ARCH" = "x86_64" ]; then
+ LIBSPATH=linux64
+ else
+ LIBSPATH=linux
+ fi
+
+ JOBS=1
+}
+
build() {
- cd ${srcdir}/$_name/scripts/linux/
+ cd ${srcdir}/${_name}
+
+ cd libs/openFrameworksCompiled/project
+
+ msg2 "Building openFrameworks Debug version"
+ make -j$JOBS Debug
+
+ msg2 "Building openFrameworks Release version"
+ make -j$JOBS Release
- msg2 "Building openFrameworks..."
- ./compileOF.sh > /dev/null
+ cd ${srcdir}/${_name}
msg2 "Building the OF Project Generator..."
- ./compilePG.sh > /dev/null
+ cd libs/openFrameworksCompiled/project
+ make -j$JOBS Release
}
package() {
diff --git a/openframeworks.install b/openframeworks.install
index 8d2cb4432cfa..c061cdf4a3b3 100644
--- a/openframeworks.install
+++ b/openframeworks.install
@@ -1,10 +1,10 @@
post_install() {
echo "The Project Generator is in /opt/openFrameworks/apps/projectGenerator/projectGeneratorSimple."
- echo -e "To initialize the workspace needed for openFrameworks launching the command: \033[0;32mof-make-workspace\033[0m"
+ echo -e "To initialize the workspace needed for openFrameworks launch the command: \033[0;32mof-make-workspace\033[0m"
echo "this command will initialize a workspace folder in your home directory."
}
post_update() {
echo -e "Remeber to regenerate your local workspace using: \033[0;32mof-make-workspace\033[0m."
- echo "If you have already a local workspace in your home, BACKUP YOUR PROJECTS BEFORE generating a new local workspace."
+ echo -e "If you already have a local workspace in your home, \033[1;31mBACKUP YOUR PROJECTS BEFORE\033[0m generating a new local workspace."
}